summaryrefslogtreecommitdiffstats
path: root/meta-extras
diff options
context:
space:
mode:
Diffstat (limited to 'meta-extras')
-rw-r--r--meta-extras/packages/sqlite/sqlite3-3.3.7/cross-compile.patch92
-rw-r--r--meta-extras/packages/sqlite/sqlite3-3.3.7/ldflags.patch67
-rw-r--r--meta-extras/packages/sqlite/sqlite3-3.3.7/libtool.patch25
-rw-r--r--meta-extras/packages/sqlite/sqlite3.inc44
-rw-r--r--meta-extras/packages/sqlite/sqlite3_3.3.7.bb2
5 files changed, 0 insertions, 230 deletions
diff --git a/meta-extras/packages/sqlite/sqlite3-3.3.7/cross-compile.patch b/meta-extras/packages/sqlite/sqlite3-3.3.7/cross-compile.patch
deleted file mode 100644
index 31d4f0d162..0000000000
--- a/meta-extras/packages/sqlite/sqlite3-3.3.7/cross-compile.patch
+++ /dev/null
@@ -1,92 +0,0 @@
---- sqlite-3.3.7/configure.ac.orig 2006-08-21 00:20:50.000000000 +0200
-+++ sqlite-3.3.7/configure.ac 2006-08-21 00:22:35.000000000 +0200
-@@ -187,10 +187,11 @@
- default_build_cflags="-g"
- if test "$config_BUILD_CC" = ""; then
- AC_PROG_CC
-- if test "$cross_compiling" = "yes"; then
-- AC_MSG_ERROR([unable to find a compiler for building build tools])
-- fi
-- BUILD_CC=$CC
-+# if test "$cross_compiling" = "yes"; then
-+# AC_MSG_ERROR([unable to find a compiler for building build tools])
-+# fi
-+# BUILD_CC=$CC
-+BUILD_CC=gcc
- default_build_cflags=$CFLAGS
- else
- BUILD_CC=$config_BUILD_CC
-@@ -238,6 +239,12 @@
- TARGET_LINK=$config_TARGET_LINK
- fi
- AC_MSG_RESULT($TARGET_LINK)
-+if test "$config_TARGET_LFLAGS" != ""; then
-+ TARGET_LFLAGS=$config_TARGET_LFLAGS
-+ else
-+ TARGET_LFLAGS=$BUILD_LFLAGS
-+ fi
-+AC_MSG_RESULT($TARGET_LFLAGS)
- AC_MSG_CHECKING([switches on the target compiler])
- if test "$config_TARGET_TFLAGS" != ""; then
- TARGET_TFLAGS=$config_TARGET_TFLAGS
-@@ -592,15 +599,7 @@
- # Figure out what C libraries are required to compile programs
- # that use "readline()" library.
- #
--if test "$config_TARGET_READLINE_LIBS" != ""; then
-- TARGET_READLINE_LIBS="$config_TARGET_READLINE_LIBS"
--else
-- CC=$TARGET_CC
-- LIBS=""
-- AC_SEARCH_LIBS(tgetent, [readline ncurses curses termcap])
-- AC_CHECK_LIB([readline], [readline])
-- TARGET_READLINE_LIBS="$LIBS"
--fi
-+TARGET_READLINE_LIBS="-lreadline"
- AC_SUBST(TARGET_READLINE_LIBS)
-
- ##########
-@@ -615,41 +614,8 @@
- ##########
- # Figure out where to get the READLINE header files.
- #
--AC_MSG_CHECKING([readline header files])
--found=no
--if test "$config_TARGET_READLINE_INC" != ""; then
-- TARGET_READLINE_INC=$config_TARGET_READLINE_INC
-- found=yes
--fi
--if test "$found" = "yes"; then
-- AC_MSG_RESULT($TARGET_READLINE_INC)
--else
-- AC_MSG_RESULT(not specified: still searching...)
-- AC_CHECK_HEADER(readline.h, [found=yes])
--fi
--if test "$found" = "no"; then
-- for dir in /usr /usr/local /usr/local/readline /usr/contrib /mingw; do
-- AC_CHECK_FILE($dir/include/readline.h, found=yes)
-- if test "$found" = "yes"; then
-- TARGET_READLINE_INC="-I$dir/include"
-- break
-- fi
-- AC_CHECK_FILE($dir/include/readline/readline.h, found=yes)
-- if test "$found" = "yes"; then
-- TARGET_READLINE_INC="-I$dir/include/readline"
-- break
-- fi
-- done
--fi
--if test "$found" = "yes"; then
-- if test "$TARGET_READLINE_LIBS" = ""; then
-- TARGET_HAVE_READLINE=0
-- else
-- TARGET_HAVE_READLINE=1
-- fi
--else
-- TARGET_HAVE_READLINE=0
--fi
-+TARGET_READLINE_INC=""
-+TARGET_HAVE_READLINE=1
- AC_SUBST(TARGET_READLINE_INC)
- AC_SUBST(TARGET_HAVE_READLINE)
-
diff --git a/meta-extras/packages/sqlite/sqlite3-3.3.7/ldflags.patch b/meta-extras/packages/sqlite/sqlite3-3.3.7/ldflags.patch
deleted file mode 100644
index ee5105ffff..0000000000
--- a/meta-extras/packages/sqlite/sqlite3-3.3.7/ldflags.patch
+++ /dev/null
@@ -1,67 +0,0 @@
---- sqlite-3.3.7/Makefile.in.orig 2006-08-20 23:05:36.000000000 +0200
-+++ sqlite-3.3.7/Makefile.in 2006-08-20 23:42:49.000000000 +0200
-@@ -31,6 +31,10 @@
- #
- TCC = @TARGET_CC@ @TARGET_CFLAGS@ -I. -I${TOP}/src
-
-+# OE overrides
-+#
-+TARGET_LFLAGS = @TARGET_LFLAGS@
-+
- # Define -DNDEBUG to compile without debugging (i.e., for production usage)
- # Omitting the define will cause extra debugging code to be inserted and
- # includes extra comments when "EXPLAIN stmt" is used.
-@@ -257,17 +261,17 @@
- | $(NAWK) '{print $$5,$$6}' >last_change
-
- libsqlite3.la: $(LIBOBJ)
-- $(LTLINK) -o libsqlite3.la $(LIBOBJ) $(LIBPTHREAD) \
-+ $(LTLINK) -o libsqlite3.la $(LIBOBJ) $(TARGET_LFLAGS) $(LIBPTHREAD) \
- ${ALLOWRELEASE} -rpath $(libdir) -version-info "8:6:8"
-
- libtclsqlite3.la: tclsqlite.lo libsqlite3.la
- $(LTLINK) -o libtclsqlite3.la tclsqlite.lo \
-- $(LIBOBJ) @TCL_STUB_LIB_SPEC@ $(LIBPTHREAD) \
-+ $(LIBOBJ) @TCL_STUB_LIB_SPEC@ $(TARGET_LFLAGS) $(LIBPTHREAD) \
- -rpath $(libdir)/sqlite \
- -version-info "8:6:8"
-
- sqlite3$(TEXE): $(TOP)/src/shell.c libsqlite3.la sqlite3.h
-- $(LTLINK) $(READLINE_FLAGS) $(LIBPTHREAD) \
-+ $(LTLINK) $(TARGET_LFLAGS) $(READLINE_FLAGS) $(LIBPTHREAD) \
- -o $@ $(TOP)/src/shell.c libsqlite3.la \
- $(LIBREADLINE) $(TLIBS)
-
-@@ -456,12 +460,12 @@
-
- tclsqlite3: tclsqlite-shell.lo libsqlite3.la
- $(LTLINK) -o tclsqlite3 tclsqlite-shell.lo \
-- libsqlite3.la $(LIBTCL)
-+ libsqlite3.la $(TARGET_LFLAGS) $(LIBTCL)
-
- testfixture$(TEXE): $(TOP)/src/tclsqlite.c libsqlite3.la $(TESTSRC)
- $(LTLINK) -DTCLSH=1 -DSQLITE_TEST=1 -DSQLITE_CRASH_TEST=1 \
- $(TEMP_STORE) -o testfixture $(TESTSRC) $(TOP)/src/tclsqlite.c \
-- libsqlite3.la $(LIBTCL)
-+ libsqlite3.la $(TARGET_LFLAGS) $(LIBTCL)
-
-
- fulltest: testfixture$(TEXE) sqlite3$(TEXE)
-@@ -471,7 +475,7 @@
- ./testfixture $(TOP)/test/quick.test
-
- sqlite3_analyzer$(TEXE): $(TOP)/src/tclsqlite.c libtclsqlite3.la \
-- $(TESTSRC) $(TOP)/tool/spaceanal.tcl
-+ $(TARGET_LFLAGS) $(TESTSRC) $(TOP)/tool/spaceanal.tcl
- sed \
- -e '/^#/d' \
- -e 's,\\,\\\\,g' \
-@@ -481,7 +485,7 @@
- $(TOP)/tool/spaceanal.tcl >spaceanal_tcl.h
- $(LTLINK) -DTCLSH=2 -DSQLITE_TEST=1 $(TEMP_STORE)\
- -o sqlite3_analyzer$(EXE) $(TESTSRC) $(TOP)/src/tclsqlite.c \
-- libtclsqlite3.la $(LIBTCL)
-+ libtclsqlite3.la $(TARGET_LFLAGS) $(LIBTCL)
-
- # Rules used to build documentation
- #
diff --git a/meta-extras/packages/sqlite/sqlite3-3.3.7/libtool.patch b/meta-extras/packages/sqlite/sqlite3-3.3.7/libtool.patch
deleted file mode 100644
index ccf9993ed2..0000000000
--- a/meta-extras/packages/sqlite/sqlite3-3.3.7/libtool.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Index: sqlite-3.2.1/Makefile.in
-===================================================================
---- sqlite-3.2.1.orig/Makefile.in 2005-03-23 17:09:39.000000000 +0100
-+++ sqlite-3.2.1/Makefile.in 2005-04-25 23:11:20.000000000 +0200
-@@ -15,7 +15,10 @@
- # The toplevel directory of the source tree. This is the directory
- # that contains this "Makefile.in" and the "configure.in" script.
- #
--TOP = @srcdir@
-+TOP = $(srcdir)
-+srcdir = @srcdir@
-+top_srcdir = @top_srcdir@
-+top_builddir = .
-
- # C Compiler and options for use in building executables that
- # will run on the platform that is doing the build.
-@@ -96,7 +99,7 @@
- exec_prefix = @exec_prefix@
- libdir = @libdir@
- INSTALL = @INSTALL@
--LIBTOOL = ./libtool
-+LIBTOOL = @LIBTOOL@
- ALLOWRELEASE = @ALLOWRELEASE@
-
- # libtool compile/link/install
diff --git a/meta-extras/packages/sqlite/sqlite3.inc b/meta-extras/packages/sqlite/sqlite3.inc
deleted file mode 100644
index 01290c2e41..0000000000
--- a/meta-extras/packages/sqlite/sqlite3.inc
+++ /dev/null
@@ -1,44 +0,0 @@
-DESCRIPTION = "An Embeddable SQL Database Engine"
-SECTION = "libs"
-PRIORITY = "optional"
-DEPENDS = "readline ncurses"
-LICENSE = "PD"
-
-SRC_URI = "http://www.sqlite.org/sqlite-${PV}.tar.gz \
- file://cross-compile.patch;patch=1 \
- file://libtool.patch;patch=1 \
- file://ldflags.patch;patch=1"
-S = "${WORKDIR}/sqlite-${PV}"
-
-inherit autotools pkgconfig
-
-EXTRA_OECONF = "--disable-tcl --enable-shared \
- --enable-threadsafe"
-export config_BUILD_CC = "${BUILD_CC}"
-export config_BUILD_CFLAGS = "${BUILD_CFLAGS}"
-export config_BUILD_LIBS = "${BUILD_LDFLAGS}"
-export config_TARGET_CC = "${CC}"
-export config_TARGET_LINK = "${CCLD}"
-export config_TARGET_CFLAGS = "${CFLAGS}"
-export config_TARGET_LFLAGS = "${LDFLAGS}"
-
-do_compile_prepend() {
- oe_runmake sqlite3.h
- install -m 0644 sqlite3.h ${STAGING_INCDIR}
-}
-
-do_stage() {
- oe_libinstall -so libsqlite3 ${STAGING_LIBDIR}
-}
-
-#do_install() {
-# oe_runmake install DESTDIR=${D} prefix=${prefix} exec_prefix=${exec_prefix}
-#}
-
-PACKAGES = "libsqlite libsqlite-dev libsqlite-doc sqlite3 sqlite3-dbg"
-FILES_sqlite3 = "${bindir}/*"
-FILES_libsqlite = "${libdir}/*.so.*"
-FILES_libsqlite-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so \
- ${libdir}/pkgconfig ${includedir}"
-FILES_libsqlite-doc = "${docdir} ${mandir} ${infodir}"
-AUTO_LIBNAME_PKGS = "libsqlite"
diff --git a/meta-extras/packages/sqlite/sqlite3_3.3.7.bb b/meta-extras/packages/sqlite/sqlite3_3.3.7.bb
deleted file mode 100644
index d21fb6ad3e..0000000000
--- a/meta-extras/packages/sqlite/sqlite3_3.3.7.bb
+++ /dev/null
@@ -1,2 +0,0 @@
-require sqlite3.inc
-PR = "r2"