summaryrefslogtreecommitdiffstats
path: root/meta-selftest/recipes-test/devtool/devtool-upgrade_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-selftest/recipes-test/devtool/devtool-upgrade_0.1.bb')
-rw-r--r--meta-selftest/recipes-test/devtool/devtool-upgrade_0.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-selftest/recipes-test/devtool/devtool-upgrade_0.1.bb b/meta-selftest/recipes-test/devtool/devtool-upgrade_0.1.bb
new file mode 100644
index 0000000000..33ffc8803a
--- /dev/null
+++ b/meta-selftest/recipes-test/devtool/devtool-upgrade_0.1.bb
@@ -0,0 +1,25 @@
+#
+# This file was derived from the 'Hello World!' example recipe in the
+# Yocto Project Development Manual.
+#
+
+DESCRIPTION = "Simple helloworld application used to test the devtool upgrade feature"
+SECTION = "devtool"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+PR = "r0"
+
+SRC_URI = "file://${THISDIR}/files/${P}.tar.gz \
+ file://0001-helloword.c-exit-with-EXIT_SUCCESS-instead-of-a-magi.patch \
+ "
+
+S = "${WORKDIR}/${P}"
+
+do_compile() {
+ ${CC} helloworld.c -o helloworld
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 helloworld ${D}${bindir}
+}