aboutsummaryrefslogtreecommitdiffstats
path: root/meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb')
-rw-r--r--meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb22
1 files changed, 16 insertions, 6 deletions
diff --git a/meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb b/meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb
index ec330fa9ff..842a9772cb 100644
--- a/meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb
+++ b/meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb
@@ -2,19 +2,29 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
LICENSE = "MIT"
-SRC_URI = "file://hello.c"
+SRC_URI = "file://hello.c \
+ file://gdb.sh \
+"
S = "${WORKDIR}"
do_compile () {
- ${CC} hello.c -o hello ${CFLAGS} ${LDFLAGS}
+ ${CC} hello.c -o hello1 ${CFLAGS} ${LDFLAGS}
}
do_install () {
install -d ${D}${bindir}
- install -m 755 hello ${D}${bindir}/hello
- ln ${D}${bindir}/hello ${D}${bindir}/hello2
- ln ${D}${bindir}/hello ${D}${bindir}/hello3
- ln ${D}${bindir}/hello ${D}${bindir}/hello4
+ install -m 755 ${WORKDIR}/gdb.sh ${D}${bindir}/
+ install -m 755 hello1 ${D}${bindir}/hello1
+ ln ${D}${bindir}/hello1 ${D}${bindir}/hello2
+
+ install -d ${D}${libexecdir}
+ ln ${D}${bindir}/hello1 ${D}${libexecdir}/hello3
+ ln ${D}${bindir}/hello1 ${D}${libexecdir}/hello4
+
dd if=/dev/zero of=${D}${bindir}/sparsetest bs=1 count=0 seek=1M
}
+
+RDEPENDS_${PN}-gdb += "gdb"
+PACKAGES =+ "${PN}-gdb"
+FILES_${PN}-gdb = "${bindir}/gdb.sh"