aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub/grub-efi-native_2.00.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/grub/grub-efi-native_2.00.bb')
-rw-r--r--meta/recipes-bsp/grub/grub-efi-native_2.00.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta/recipes-bsp/grub/grub-efi-native_2.00.bb b/meta/recipes-bsp/grub/grub-efi-native_2.00.bb
index 2d3d68a9b8..04973b524f 100644
--- a/meta/recipes-bsp/grub/grub-efi-native_2.00.bb
+++ b/meta/recipes-bsp/grub/grub-efi-native_2.00.bb
@@ -23,6 +23,7 @@ PR = "r2"
PN := "grub-efi-${TRANSLATED_TARGET_ARCH}-native"
SRC_URI = "ftp://ftp.gnu.org/gnu/grub/grub-${PV}.tar.gz \
+ file://cfg \
file://grub-2.00-fpmath-sse-387-fix.patch \
file://grub-2.00-fix-enable_execute_stack-check.patch \
file://grub-2.00-disable-help2man.patch \
@@ -66,9 +67,11 @@ EXTRA_OECONF = "--with-platform=efi --disable-grub-mkfont \
--enable-liblzma=no --enable-device-mapper=no --enable-libzfs=no"
do_mkimage() {
- ./grub-mkimage -p /EFI/BOOT -d ./grub-core/ \
+ # Search for the grub.cfg on the local boot media by using the
+ # built in cfg file provided via this recipe
+ ./grub-mkimage -c ../cfg -p /EFI/BOOT -d ./grub-core/ \
-O ${GRUB_TARGET}-efi -o ./${GRUB_IMAGE} \
- boot linux ext2 fat serial part_msdos part_gpt normal efi_gop
+ boot linux ext2 fat serial part_msdos part_gpt normal efi_gop iso9660 search
}
addtask mkimage after do_compile before do_install