summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/setserial/setserial_2.17.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/setserial/setserial_2.17.bb')
-rw-r--r--meta/recipes-bsp/setserial/setserial_2.17.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-bsp/setserial/setserial_2.17.bb b/meta/recipes-bsp/setserial/setserial_2.17.bb
new file mode 100644
index 0000000000..4e0d1b66e4
--- /dev/null
+++ b/meta/recipes-bsp/setserial/setserial_2.17.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "setserial is a program designed to set and/or report the configuration information associated with a serial port"
+HOMEPAGE = "http://setserial.sourceforge.net"
+AUTHOR = "Theodore Ts'o <tytso@mit.edu>"
+SECTION = "console/utils"
+LICENSE = "GPL"
+PR = "r2"
+
+inherit autotools
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/setserial/${PN}-${PV}.tar.gz"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${mandir}/man8
+
+ install -m 0755 ${S}/setserial ${D}${bindir}
+ install -m 0644 ${S}/setserial.8 ${D}${mandir}/man8
+}