summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/zaurus-updater/encdec-updater.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/zaurus-updater/encdec-updater.bb')
-rw-r--r--meta/recipes-bsp/zaurus-updater/encdec-updater.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-bsp/zaurus-updater/encdec-updater.bb b/meta/recipes-bsp/zaurus-updater/encdec-updater.bb
new file mode 100644
index 0000000000..c59d0e2976
--- /dev/null
+++ b/meta/recipes-bsp/zaurus-updater/encdec-updater.bb
@@ -0,0 +1,18 @@
+SECTION = "console/utils"
+LICENSE = "GPL"
+DESCRIPTION = "A tool to encode and decode the Sharp Zaurus updater.sh script"
+
+SRC_URI = "file://encdec-updater.c"
+
+COMPATIBLE_MACHINE = '(poodle|c7x0|spitz|akita|tosa)'
+
+do_compile() {
+ ${CC} -o encdec-updater ${WORKDIR}/encdec-updater.c
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 encdec-updater ${D}${bindir}/
+}
+
+BBCLASSEXTEND = "native" \ No newline at end of file