summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/wbxml/wbxml2_0.9.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/wbxml/wbxml2_0.9.2.bb')
-rw-r--r--meta/recipes-connectivity/wbxml/wbxml2_0.9.2.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/wbxml/wbxml2_0.9.2.bb b/meta/recipes-connectivity/wbxml/wbxml2_0.9.2.bb
new file mode 100644
index 0000000000..b8ba8c747f
--- /dev/null
+++ b/meta/recipes-connectivity/wbxml/wbxml2_0.9.2.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "parser for wbxml"
+LICENSE = "GPLv2"
+
+DEPENDS = "libxml2 sed-native expat"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/wbxmllib/${P}.tar.gz \
+ file://no-doc-install.patch;patch=1"
+
+inherit autotools pkgconfig
+
+do_configure_append() {
+ sed -i s:-I/usr/include::g Makefile
+ sed -i s:-I/usr/include::g */Makefile
+}
+
+PACKAGES += "${PN}-tools"
+
+FILES_${PN}-tools = "${bindir}"
+FILES_${PN} = "${libdir}/*.so.*"
+