summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go_1.16.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/go/go_1.16.15.bb')
-rw-r--r--meta/recipes-devtools/go/go_1.16.15.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go_1.16.15.bb b/meta/recipes-devtools/go/go_1.16.15.bb
new file mode 100644
index 0000000000..4e9e0ebec8
--- /dev/null
+++ b/meta/recipes-devtools/go/go_1.16.15.bb
@@ -0,0 +1,17 @@
+require go-${PV}.inc
+require go-target.inc
+
+inherit linuxloader
+
+export GOBUILDMODE=""
+export GO_LDSO = "${@get_linuxloader(d)}"
+export CC_FOR_TARGET = "gcc"
+export CXX_FOR_TARGET = "g++"
+
+# mips/rv64 doesn't support -buildmode=pie, so skip the QA checking for mips/riscv32 and its
+# variants.
+python() {
+ if 'mips' in d.getVar('TARGET_ARCH',True) or 'riscv32' in d.getVar('TARGET_ARCH',True):
+ d.appendVar('INSANE_SKIP_%s' % d.getVar('PN',True), " textrel")
+}
+