summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rsync/rsync_3.2.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/rsync/rsync_3.2.3.bb')
-rw-r--r--meta/recipes-devtools/rsync/rsync_3.2.3.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-devtools/rsync/rsync_3.2.3.bb b/meta/recipes-devtools/rsync/rsync_3.2.3.bb
index cb18667755..6168ee85fc 100644
--- a/meta/recipes-devtools/rsync/rsync_3.2.3.bb
+++ b/meta/recipes-devtools/rsync/rsync_3.2.3.bb
@@ -3,9 +3,9 @@ HOMEPAGE = "http://rsync.samba.org/"
DESCRIPTION = "rsync is an open source utility that provides fast incremental file transfer."
BUGTRACKER = "http://rsync.samba.org/bugzilla.html"
SECTION = "console/network"
-# GPLv2+ (<< 3.0.0), GPLv3+ (>= 3.0.0)
+# GPL-2.0-or-later (<< 3.0.0), GPL-3.0-or-later (>= 3.0.0)
# Includes opennsh and xxhash dynamic link exception
-LICENSE = "GPLv3+"
+LICENSE = "GPL-3.0-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=9e5a4f9b3a253d51520617aa54f8eb26"
DEPENDS = "popt"
@@ -20,7 +20,7 @@ SRC_URI = "https://download.samba.org/pub/${BPN}/src/${BP}.tar.gz \
SRC_URI[sha256sum] = "becc3c504ceea499f4167a260040ccf4d9f2ef9499ad5683c179a697146ce50e"
# -16548 required for v3.1.3pre1. Already in v3.1.3.
-CVE_CHECK_WHITELIST += " CVE-2017-16548 "
+CVE_CHECK_IGNORE += " CVE-2017-16548 "
inherit autotools-brokensep
@@ -45,15 +45,15 @@ EXTRA_OECONF = "--disable-simd --disable-md2man --disable-asm --with-nobody-grou
# rsync 3.0 uses configure.sh instead of configure, and
# makefile checks the existence of configure.sh
-do_configure_prepend () {
+do_configure:prepend () {
rm -f ${S}/configure ${S}/configure.sh
}
-do_configure_append () {
+do_configure:append () {
cp -f ${S}/configure ${S}/configure.sh
}
-do_install_append() {
+do_install:append() {
install -d ${D}${sysconfdir}
install -m 0644 ${WORKDIR}/rsyncd.conf ${D}${sysconfdir}
}