aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/pbzip2/pbzip2_1.1.13.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/pbzip2/pbzip2_1.1.13.bb')
-rw-r--r--meta/recipes-extended/pbzip2/pbzip2_1.1.13.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta/recipes-extended/pbzip2/pbzip2_1.1.13.bb b/meta/recipes-extended/pbzip2/pbzip2_1.1.13.bb
index b3c5975811..67fb2ef9c5 100644
--- a/meta/recipes-extended/pbzip2/pbzip2_1.1.13.bb
+++ b/meta/recipes-extended/pbzip2/pbzip2_1.1.13.bb
@@ -22,6 +22,18 @@ do_configure[noexec] = "1"
EXTRA_OEMAKE = "CXX='${CXX} ${CXXFLAGS}' LDFLAGS='${LDFLAGS}'"
+do_compile_prepend() {
+ # Update timestamp to fix rebuild
+ src_files="pbzip2.cpp BZ2StreamScanner.cpp ErrorContext.cpp"
+ for f in $src_files; do
+ if [ -f $f ]; then
+ touch $f
+ else
+ bbwarn "Regular file $f not found"
+ fi
+ done
+}
+
do_install() {
install -d ${D}${bindir}
install -m 0755 pbzip2 ${D}${bindir}/