aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/sed/sed-4.2.2/sed-add-ptest.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/sed/sed-4.2.2/sed-add-ptest.patch')
-rw-r--r--meta/recipes-extended/sed/sed-4.2.2/sed-add-ptest.patch2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-extended/sed/sed-4.2.2/sed-add-ptest.patch b/meta/recipes-extended/sed/sed-4.2.2/sed-add-ptest.patch
index 105e8b745b..0293900fbf 100644
--- a/meta/recipes-extended/sed/sed-4.2.2/sed-add-ptest.patch
+++ b/meta/recipes-extended/sed/sed-4.2.2/sed-add-ptest.patch
@@ -54,7 +54,7 @@ index d80e72c..b05f01e 100644
# dummy targets for $(TESTS) so that make does not complain.
+install-ptest:
-+ cd $(BUILDDIR); tar -cf - $(TESTDIR) --exclude *.o | ( cd $(DESTDIR) && tar -xf - )
++ cd $(BUILDDIR); tar -c --exclude=*.o $(TESTDIR) | ( cd $(DESTDIR) && tar -xf - )
+ for i in $(EXTRA_DIST) tst-regex2.c; do install $(srcdir)/$$i $(DESTDIR)/$(TESTDIR); done
+ sed -e 's/^Makefile:/_Makefile:/' -e 's/^srcdir = \(.*\)/srcdir = ./' -e 's/bash/sh/' -i $(DESTDIR)/$(TESTDIR)/Makefile
+ for i in `grep -rl "../sed/sed" $(DESTDIR)/$(TESTDIR)`; do sed -e 's/..\/sed\/sed/sed/' -i $$i; done