summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib/xkeyboard-config_1.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/xorg-lib/xkeyboard-config_1.9.bb')
-rw-r--r--meta/recipes-graphics/xorg-lib/xkeyboard-config_1.9.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-lib/xkeyboard-config_1.9.bb b/meta/recipes-graphics/xorg-lib/xkeyboard-config_1.9.bb
new file mode 100644
index 0000000000..0e59bd506f
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/xkeyboard-config_1.9.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Keyboard configuration database for X Window"
+HOMEPAGE = "http://freedesktop.org/wiki/Software/XKeyboardConfig"
+BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=xkeyboard-config"
+
+LICENSE = "MIT & MIT-style"
+LIC_FILES_CHKSUM = "file://COPYING;md5=0e7f21ca7db975c63467d2e7624a12f9"
+
+SRC_URI = "http://people.freedesktop.org/~svu/xkeyboard-config-${PV}.tar.bz2"
+SECTION = "x11/libs"
+DEPENDS = "intltool xkbcomp-native glib-2.0"
+
+PR = "r0"
+
+EXTRA_OECONF = "--with-xkb-rules-symlink=xorg"
+
+RDEPENDS_${PN} += "xkbcomp"
+FILES_${PN} += "${datadir}/X11/xkb"
+
+inherit autotools pkgconfig
+
+do_install_append () {
+ install -d ${D}/usr/share/X11/xkb/compiled
+ cd ${D}${datadir}/X11/xkb/rules && ln -sf base xorg
+}