aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/modutils/modutils-collateral.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/modutils/modutils-collateral.bb')
-rw-r--r--meta/recipes-kernel/modutils/modutils-collateral.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-kernel/modutils/modutils-collateral.bb b/meta/recipes-kernel/modutils/modutils-collateral.bb
new file mode 100644
index 0000000000..6d010a5754
--- /dev/null
+++ b/meta/recipes-kernel/modutils/modutils-collateral.bb
@@ -0,0 +1,21 @@
+SECTION = "base"
+DESCRIPTION = "modutils configuration files"
+PR = "r3"
+LICENSE = "MIT"
+
+SRC_URI = "file://modules \
+ file://modules.conf"
+
+do_compile () {
+}
+
+do_install () {
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/modules ${D}${sysconfdir}/modules
+ if [ ${MAJOR_KERNEL_VERSION}=2.6 ]; then
+ install -d ${D}${sysconfdir}/modprobe.d
+ else
+ install -m 0644 ${WORKDIR}/modules.conf ${D}${sysconfdir}/modules.conf
+ fi
+
+}