summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Madison <matt@madison.systems>2018-04-21 06:19:37 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-04-23 11:15:06 +0100
commitb1783e423444e0432d2653fbd00c18d119d82647 (patch)
treeba03b43ad47d28cacba209b9d6be4ad3a327e942
parent802a2877a78a44c17f3e142f7d12017a08d09dad (diff)
downloadopenembedded-core-b1783e423444e0432d2653fbd00c18d119d82647.tar.gz
go-runtime_1.9: pass BUILD_ flags to cgo for host-side build
When running the make.bash script to build the host-side tools, make sure that cgo is using CFLAGS and LDFLAGS for the build host, rather than those for the target. [YOCTO #12704] Signed-off-by: Matt Madison <matt@madison.systems> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/go/go-runtime_1.9.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/go/go-runtime_1.9.bb b/meta/recipes-devtools/go/go-runtime_1.9.bb
index a99cc30f63..d5279ea897 100644
--- a/meta/recipes-devtools/go/go-runtime_1.9.bb
+++ b/meta/recipes-devtools/go/go-runtime_1.9.bb
@@ -11,7 +11,7 @@ do_compile() {
export CC=$BUILD_CC
cd src
- ./make.bash --host-only
+ CGO_CFLAGS="${BUILD_CFLAGS}" CGO_LDFLAGS="${BUILD_LDFLAGS}" ./make.bash --host-only
cp ${B}/pkg/tool/${BUILD_GOTUPLE}/go_bootstrap ${B}
rm -rf ${B}/pkg/${TARGET_GOTUPLE}
./make.bash --target-only