summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-01-12 23:41:23 -0500
committerAnuj Mittal <anuj.mittal@intel.com>2020-07-17 09:36:52 +0800
commit3269e3d2d0258ac3788ed63fa46df4d4aae33b1e (patch)
treecc454e49979702e80ef6db9c03ab263b5c7cb5b9
parentd9e58aff76edf1f5fdc31785fd81fae2c7c508c8 (diff)
downloadopenembedded-core-3269e3d2d0258ac3788ed63fa46df4d4aae33b1e.tar.gz
perf: fix build for v5.5+
In kernel 5.5+ there are python3 scripts that explicitly use /usr/bin/python3 as the interpreter. That will find the host python and produce undefined results. We add that interpreter path to our substitutions to ensure that our sysroot variant is used. (From OE-Core rev: 103316d50d4947b3c3500eb5cbc4845702a62d22) Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit e5c4f3127521607742f7cdf62481b64cf4d3e828) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--meta/recipes-kernel/perf/perf.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 90f05c0e62..d707b580e2 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -237,6 +237,7 @@ do_configure_prepend () {
sed -i 's,/usr/bin/python,/usr/bin/env python3,' "${s}"
sed -i 's,/usr/bin/python2,/usr/bin/env python3,' "${s}"
sed -i 's,/usr/bin/env python2,/usr/bin/env python3,' "${s}"
+ sed -i 's,/usr/bin/python3,/usr/bin/env python3,' "${s}"
done
# unistd.h can be out of sync between libc-headers and the captured version in the perf source