summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.z@gmail.com>2021-12-08 14:21:18 -0600
committerSteve Sakoman <steve@sakoman.com>2021-12-11 05:21:06 -1000
commitdb8a8b53f440f37731c7c5db9561ac46ef59d891 (patch)
tree47e59a54d006ab9d976453d431165632e32864f5
parent3c8e50b073a1505cc3586ca51dfe1e75338feafc (diff)
downloadopenembedded-core-db8a8b53f440f37731c7c5db9561ac46ef59d891.tar.gz
lttng-modules: do not search in non-existing folder during install
When CONFIG_TRACEPOINTS is not enabled in kernel config - module compilation is skipped, which causes the ${D}/${nonarch_base_libdir} not to be created. This fails later in do_install:append() due to the fact that find command in executed for non-existing folder. Check for folder existence before find command in executed. Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit de0aa1700ed4e6f04b0a233eb1f6d2ac598e7ed8) Signed-off-by: Aníbal Limón <anibal.limon@linaro.org> Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.11.6.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.11.6.bb b/meta/recipes-kernel/lttng/lttng-modules_2.11.6.bb
index 3fdc8094e9..3145f0298c 100644
--- a/meta/recipes-kernel/lttng/lttng-modules_2.11.6.bb
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.11.6.bb
@@ -39,7 +39,9 @@ EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
do_install_append() {
# Delete empty directories to avoid QA failures if no modules were built
- find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
+ if [ -d ${D}/${nonarch_base_libdir} ]; then
+ find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
+ fi
}
python do_package_prepend() {