aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei@gherzan.ro>2012-07-17 13:39:26 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-19 17:08:39 +0100
commit09203299c666791ce35d5a897fd1aa2b0d281dd6 (patch)
tree8d3265e1a6490d390cc976e06ded3e9dfc5de71d
parent59f4d7537f7662ed82238f0be2626a1940789433 (diff)
downloadopenembedded-core-09203299c666791ce35d5a897fd1aa2b0d281dd6.tar.gz
connman: Add patches to fix connman on fs with no d_type support
When there is not d_type avalaible on filesystem, fstatat (stat) can be used to check if the path is a directory. storage.c and timezone.c were modified accordingly. Signed-off-by: Andrei Gherzan <andrei.gherzan@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-connectivity/connman/connman/0001-timezone.c-If-there-is-no-d_type-support-use-fstatat.patch61
-rw-r--r--meta/recipes-connectivity/connman/connman/0002-storage.c-If-there-is-no-d_type-support-use-fstatat.patch49
-rw-r--r--meta/recipes-connectivity/connman/connman_1.3.bb6
3 files changed, 114 insertions, 2 deletions
diff --git a/meta/recipes-connectivity/connman/connman/0001-timezone.c-If-there-is-no-d_type-support-use-fstatat.patch b/meta/recipes-connectivity/connman/connman/0001-timezone.c-If-there-is-no-d_type-support-use-fstatat.patch
new file mode 100644
index 0000000000..3bced52054
--- /dev/null
+++ b/meta/recipes-connectivity/connman/connman/0001-timezone.c-If-there-is-no-d_type-support-use-fstatat.patch
@@ -0,0 +1,61 @@
+From f2094e6b2e4542adf458d8fa58d7bccd5edb762e Mon Sep 17 00:00:00 2001
+From: Andrei Gherzan <andrei@gherzan.ro>
+Date: Tue, 17 Jul 2012 17:27:39 +0300
+Subject: [PATCH V3 1/2] timezone.c: If there is no d_type support use
+ fstatat()
+
+This is useful for filesystems where d_type is always DT_UNKNOWN.
+In this case use fstatat() function.
+
+Signed-off-by: Andrei Gherzan <andrei.gherzan@windriver.com>
+Upstream-Status: Submitted
+
+---
+ src/timezone.c | 24 ++++++++++++++++++++++++
+ 1 file changed, 24 insertions(+)
+
+diff --git a/src/timezone.c b/src/timezone.c
+index 173d658..f951f6b 100644
+--- a/src/timezone.c
++++ b/src/timezone.c
+@@ -157,6 +157,8 @@ static char *find_origin(void *src_map, struct stat *src_st,
+ DIR *dir;
+ struct dirent *d;
+ char *str, pathname[PATH_MAX];
++ struct stat buf;
++ int ret;
+
+ if (subpath == NULL)
+ strncpy(pathname, basepath, sizeof(pathname));
+@@ -205,6 +207,28 @@ static char *find_origin(void *src_map, struct stat *src_st,
+ return str;
+ }
+ break;
++ case DT_UNKNOWN:
++ /*
++ * If there is no d_type support use fstatat()
++ * to check if directory
++ */
++ ret = fstatat(dirfd(dir), d->d_name, &buf, 0);
++ if (ret < 0)
++ continue;
++ if (!(buf.st_mode & S_IFDIR))
++ continue;
++ if (subpath == NULL)
++ strncpy(pathname, d->d_name, sizeof(pathname));
++ else
++ snprintf(pathname, sizeof(pathname),
++ "%s/%s", subpath, d->d_name);
++
++ str = find_origin(src_map, src_st, basepath, pathname);
++ if (str != NULL) {
++ closedir(dir);
++ return str;
++ }
++ break;
+ }
+ }
+
+--
+1.7.9.5
+
diff --git a/meta/recipes-connectivity/connman/connman/0002-storage.c-If-there-is-no-d_type-support-use-fstatat.patch b/meta/recipes-connectivity/connman/connman/0002-storage.c-If-there-is-no-d_type-support-use-fstatat.patch
new file mode 100644
index 0000000000..d3205c0e68
--- /dev/null
+++ b/meta/recipes-connectivity/connman/connman/0002-storage.c-If-there-is-no-d_type-support-use-fstatat.patch
@@ -0,0 +1,49 @@
+From 7007ef32a959ac4717c19339a24fd90a68638a19 Mon Sep 17 00:00:00 2001
+From: Andrei Gherzan <andrei@gherzan.ro>
+Date: Tue, 17 Jul 2012 16:07:17 +0300
+Subject: [PATCH V3 2/2] storage.c: If there is no d_type support use
+ fstatat()
+
+This is useful for filesystems where d_type is always DT_UNKNOWN.
+In this case use fstatat() function.
+
+Signed-off-by: Andrei Gherzan <andrei.gherzan@windriver.com>
+Upstream-Status: Submitted
+
+---
+ src/storage.c | 19 +++++++++++++++++++
+ 1 file changed, 19 insertions(+)
+
+diff --git a/src/storage.c b/src/storage.c
+index 47bd0cb..0491a52 100644
+--- a/src/storage.c
++++ b/src/storage.c
+@@ -206,6 +206,25 @@ gchar **connman_storage_get_services()
+
+ g_string_append_printf(result, "%s/", d->d_name);
+ break;
++ case DT_UNKNOWN:
++ /*
++ * If there is no d_type support use fstatat()
++ * to check if directory
++ */
++ ret = fstatat(dirfd(dir), d->d_name, &buf, 0);
++ if (ret < 0)
++ continue;
++ if (!(buf.st_mode & S_IFDIR))
++ continue;
++ str = g_strdup_printf("%s/%s/settings", STORAGEDIR,
++ d->d_name);
++ ret = stat(str, &buf);
++ g_free(str);
++ if (ret < 0)
++ continue;
++
++ g_string_append_printf(result, "%s/", d->d_name);
++ break;
+ }
+ }
+
+--
+1.7.9.5
+
diff --git a/meta/recipes-connectivity/connman/connman_1.3.bb b/meta/recipes-connectivity/connman/connman_1.3.bb
index 1e3d138fc2..a98b46ca1b 100644
--- a/meta/recipes-connectivity/connman/connman_1.3.bb
+++ b/meta/recipes-connectivity/connman/connman_1.3.bb
@@ -5,6 +5,8 @@ SRCREV = "3c0fa84091524c7cd6237744f2088ffee2f1d5ad"
SRC_URI = "git://git.kernel.org/pub/scm/network/connman/connman.git \
file://0001-plugin.h-Change-visibility-to-default-for-debug-symb.patch \
file://add_xuser_dbus_permission.patch \
- file://connman"
+ file://connman \
+ file://0002-storage.c-If-there-is-no-d_type-support-use-fstatat.patch \
+ file://0001-timezone.c-If-there-is-no-d_type-support-use-fstatat.patch"
S = "${WORKDIR}/git"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"