summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2023-03-24 11:08:48 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-03-26 18:48:56 +0100
commit14b815b0beb6edc14b4fcc016201ade967875e28 (patch)
tree268fb3b8b6f60d849e508109ae211763faef8a8d
parent150ac6445301b944b05ea6b9952ebb7d41707c42 (diff)
downloadopenembedded-core-14b815b0beb6edc14b4fcc016201ade967875e28.tar.gz
kernel/kernel-devsrc: powerpc: add elfutils dependency
When working on 6.3+ kernel support powerpc started to fail when doing on target kerne module builds, and in some cases when building the kernel itself. This was due to crtsavres requiring objtool to build, which was missing required development headers. So in a similar manner to x86, we add elfutils as an arch specific dependency in these recipes. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/kernel-devsrc.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-dev.bb1
2 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/kernel-devsrc.bb b/meta/recipes-kernel/linux/kernel-devsrc.bb
index ab965272d9..b4ea5f756a 100644
--- a/meta/recipes-kernel/linux/kernel-devsrc.bb
+++ b/meta/recipes-kernel/linux/kernel-devsrc.bb
@@ -382,6 +382,8 @@ RDEPENDS:${PN} = "bc python3 flex bison ${TCLIBC}-utils"
RDEPENDS:${PN} += "openssl-dev util-linux"
# and x86 needs a bit more for 4.15+
RDEPENDS:${PN} += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-dev', '', d)}"
+# powerpc needs elfutils on 6.3+
+RDEPENDS:${PN} += "${@bb.utils.contains('ARCH', 'powerpc', 'elfutils-dev', '', d)}"
# 5.8+ needs gcc-plugins libmpc-dev
RDEPENDS:${PN} += "gcc-plugins libmpc-dev"
# 5.13+ needs awk for arm64
diff --git a/meta/recipes-kernel/linux/linux-yocto-dev.bb b/meta/recipes-kernel/linux/linux-yocto-dev.bb
index 4f3d4a5c3c..52cd6f5f28 100644
--- a/meta/recipes-kernel/linux/linux-yocto-dev.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-dev.bb
@@ -35,6 +35,7 @@ PV = "${LINUX_VERSION}+git${SRCPV}"
LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
+DEPENDS += "${@bb.utils.contains('ARCH', 'powerpc', 'elfutils-native', '', d)}"
DEPENDS += "openssl-native util-linux-native"
DEPENDS += "gmp-native libmpc-native"