summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2018-05-09 14:46:48 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-15 10:00:30 +0100
commitf3d223304e52b9be946e5bd849075147147cbbb3 (patch)
tree8a5b447043ca588b8e65973857480f31f2a5a6eb
parentd3653e8525e048d9968b949dbff5304c1fd94480 (diff)
downloadopenembedded-core-f3d223304e52b9be946e5bd849075147147cbbb3.tar.gz
rpm: move ASNEEDED over-ride into the rpm recipe
Move the recipe specific over-ride for ASNEEDED into the recipe to make it more apparent that the over-ride is being applied (and that it should be re-checked on version updates, etc). Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/conf/distro/include/as-needed.inc1
-rw-r--r--meta/recipes-devtools/rpm/rpm_4.14.1.bb2
2 files changed, 2 insertions, 1 deletions
diff --git a/meta/conf/distro/include/as-needed.inc b/meta/conf/distro/include/as-needed.inc
index f56d432bd5..9c235649b7 100644
--- a/meta/conf/distro/include/as-needed.inc
+++ b/meta/conf/distro/include/as-needed.inc
@@ -2,6 +2,5 @@
ASNEEDED = "-Wl,--as-needed"
ASNEEDED_pn-openobex = ""
-ASNEEDED_pn-rpm = ""
TARGET_LDFLAGS += "${ASNEEDED}"
diff --git a/meta/recipes-devtools/rpm/rpm_4.14.1.bb b/meta/recipes-devtools/rpm/rpm_4.14.1.bb
index 818d3ef9e3..d49530e0b9 100644
--- a/meta/recipes-devtools/rpm/rpm_4.14.1.bb
+++ b/meta/recipes-devtools/rpm/rpm_4.14.1.bb
@@ -73,6 +73,8 @@ BBCLASSEXTEND = "native nativesdk"
PACKAGECONFIG ??= ""
PACKAGECONFIG[imaevm] = "--with-imaevm,,ima-evm-utils"
+ASNEEDED = ""
+
# Direct rpm-native to read configuration from our sysroot, not the one it was compiled in
# libmagic also has sysroot path contamination, so override it
do_install_append_class-native() {