summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarta Rybczynska <rybczynska@gmail.com>2022-05-02 16:25:35 +0200
committerSteve Sakoman <steve@sakoman.com>2022-05-10 08:23:11 -1000
commitd0a56ad3a278e18e766f833619cf97869bdf6a4c (patch)
treeafab9e446f38445273f3c6128f6c9dbca18a9b2b
parent72e5204bc7272414cc7bcfba18f52a177242ed79 (diff)
downloadopenembedded-core-d0a56ad3a278e18e766f833619cf97869bdf6a4c.tar.gz
cve-update-db-native: update the CVE database once a day only
The update of the NVD database was expected to happen once per hour. However, the database file date changes only if the content was actually updated. In practice, the check worked for the first hour after the new download. As the NVD database changes usually only once a day, we can just update it less frequently. Signed-off-by: Marta Rybczynska <marta.rybczynska@huawei.com> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 35bccdedadeaba820d58b69fe74ce5e4c1f577e3) Signed-off-by: Steve Sakoman <steve@sakoman.com> (cherry picked from commit 88f2fb1581a17b2cf59a694ca9afb89e38ed40b5) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-core/meta/cve-update-db-native.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-core/meta/cve-update-db-native.bb b/meta/recipes-core/meta/cve-update-db-native.bb
index 50052f8532..a6144979f0 100644
--- a/meta/recipes-core/meta/cve-update-db-native.bb
+++ b/meta/recipes-core/meta/cve-update-db-native.bb
@@ -42,10 +42,10 @@ python do_fetch() {
if os.path.exists(db_file):
os.remove(db_file)
- # Don't refresh the database more than once an hour
+ # The NVD database changes once a day, so no need to update more frequently
try:
import time
- if time.time() - os.path.getmtime(db_file) < (60*60):
+ if time.time() - os.path.getmtime(db_file) < (24*60*60):
return
except OSError:
pass