summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJon Mason <jdmason@kudzu.us>2022-04-08 15:25:21 -0400
committerSteve Sakoman <steve@sakoman.com>2022-05-09 04:01:07 -1000
commit617e13b1af686f0713589b10b2f094a34f588b9d (patch)
tree7e07dc215897dedc79e5718ec50c0f87891436ae
parentcfea7f69f780502899925df374e6ad9f73e219d1 (diff)
downloadopenembedded-core-617e13b1af686f0713589b10b2f094a34f588b9d.tar.gz
poky-tiny: enable qemuarmv5/qemuarm64 and cleanups
Add support for qemuarmv5 and qemuarm64, and remove qemuarm specific entries, as it should be generic now. Signed-off-by: Jon Mason <jdmason@kudzu.us> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 9bd21e1130155ad1ec704e0151a22e9f84bfaa78) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb4
1 files changed, 1 insertions, 3 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
index d8ce5dc518..43a5ad728a 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
@@ -1,5 +1,4 @@
KBRANCH ?= "v5.15/standard/tiny/base"
-KBRANCH:qemuarm ?= "v5.15/standard/tiny/arm-versatile-926ejs"
LINUX_KERNEL_TYPE = "tiny"
KCONFIG_MODE = "--allnoconfig"
@@ -15,7 +14,6 @@ DEPENDS += "openssl-native util-linux-native"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine:qemuarm ?= "cc9e92e826af229b841fcaf8c645e638a86eba43"
SRCREV_machine ?= "c3d54a67cbf3fb8e6df2d88c80e9d2c74f69aba4"
SRCREV_meta ?= "63e25b5717751b4b33685bd5991d10c52934a4c6"
@@ -24,7 +22,7 @@ PV = "${LINUX_VERSION}+git${SRCPV}"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.15;destsuffix=${KMETA}"
-COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm|qemuarmv5"
+COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm64|qemuarm|qemuarmv5"
# Functionality flags
KERNEL_FEATURES = ""