summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2022-06-04 23:50:43 +0100
committerSteve Sakoman <steve@sakoman.com>2022-06-09 06:10:26 -1000
commit6b1bc1366bf88ec3b77fe9db44813c4dfd545a7d (patch)
treeab52dbb43a244da892e3683a8253cb37ad8d2c05
parent4b694ded86877cce06af65a0f542027d7408c111 (diff)
downloadopenembedded-core-6b1bc1366bf88ec3b77fe9db44813c4dfd545a7d.tar.gz
perl: Add dependency on make-native to avoid race issues
Make 4.1 has race issues with double colon usage in makefiles which are common in MakeMaker generated code in perl. Add a dependency on make-native to avoid this as it is relaitvely low overhead. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 692b7c518637c77804caf7b3cfc60a83afa2e4f4) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-devtools/perl/perl_5.34.1.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.34.1.bb b/meta/recipes-devtools/perl/perl_5.34.1.bb
index 4b9d2e2c50..42bcb8b1bc 100644
--- a/meta/recipes-devtools/perl/perl_5.34.1.bb
+++ b/meta/recipes-devtools/perl/perl_5.34.1.bb
@@ -33,6 +33,8 @@ S = "${WORKDIR}/perl-${PV}"
inherit upstream-version-is-even update-alternatives
DEPENDS += "perlcross-native zlib virtual/crypt"
+# make 4.1 has race issues with the double-colon usage of MakeMaker, see #14096
+DEPENDS += "make-native"
PERL_LIB_VER = "${@'.'.join(d.getVar('PV').split('.')[0:2])}.0"