summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2013-04-21 14:43:10 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-29 14:43:52 +0100
commit0273f31d20f3e3c24e8b309f928595885eb04af2 (patch)
treefa7f6372eed048d391f8db7353db442d95ad4f5b
parent28e185ba401fa1f2c11fca65bd873a0f5d78b811 (diff)
downloadopenembedded-core-0273f31d20f3e3c24e8b309f928595885eb04af2.tar.gz
glew: fix generation of glew.pc needed by mesa-demos
Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-graphics/glew/files/fix-glew.pc-install.patch44
-rw-r--r--meta/recipes-graphics/glew/glew_1.9.0.bb1
2 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-graphics/glew/files/fix-glew.pc-install.patch b/meta/recipes-graphics/glew/files/fix-glew.pc-install.patch
new file mode 100644
index 0000000000..5b6a94e471
--- /dev/null
+++ b/meta/recipes-graphics/glew/files/fix-glew.pc-install.patch
@@ -0,0 +1,44 @@
+
+We maintain the autotools configure.ac and Makefile.am, to correctly
+provide the glew.pc, the following patch is needed.
+
+Upstream-Status: Inappropriate
+
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
+
+Index: glew-1.9.0/Makefile.am
+===================================================================
+--- glew-1.9.0.orig/Makefile.am
++++ glew-1.9.0/Makefile.am
+@@ -3,3 +3,5 @@ ACLOCAL_AMFLAGS = -I m4 --install
+
+ SUBDIRS = include src
+
++pkgconfigdir = $(libdir)/pkgconfig
++pkgconfig_DATA = glew.pc
+Index: glew-1.9.0/configure.ac
+===================================================================
+--- glew-1.9.0.orig/configure.ac
++++ glew-1.9.0/configure.ac
+@@ -66,5 +66,6 @@ AC_SUBST([LIBGLEW_SO_VERSION], [1:5:7])
+
+ AC_CONFIG_FILES([Makefile
+ include/Makefile
+- src/Makefile])
++ src/Makefile
++ glew.pc])
+ AC_OUTPUT
+Index: glew-1.9.0/glew.pc.in
+===================================================================
+--- glew-1.9.0.orig/glew.pc.in
++++ glew-1.9.0/glew.pc.in
+@@ -5,6 +5,6 @@ includedir=@includedir@
+
+ Name: glew
+ Description: The OpenGL Extension Wrangler library
+-Version: @version@
+-Cflags: -I${includedir} @cflags@
+-Libs: -L${libdir} -l@libname@
++Version: @VERSION@
++Cflags: -I${includedir} @CFLAGS@
++Libs: -L${libdir} -lGLEW
diff --git a/meta/recipes-graphics/glew/glew_1.9.0.bb b/meta/recipes-graphics/glew/glew_1.9.0.bb
index 599d64bceb..f1ba4e43da 100644
--- a/meta/recipes-graphics/glew/glew_1.9.0.bb
+++ b/meta/recipes-graphics/glew/glew_1.9.0.bb
@@ -12,6 +12,7 @@ PR = "r1"
SRC_URI = "${SOURCEFORGE_MIRROR}/project/glew/glew/${PV}/glew-${PV}.tgz \
file://autotools.patch \
file://glew_fix_for_automake-1.12.patch \
+ file://fix-glew.pc-install.patch \
"
SRC_URI[md5sum] = "69ce911decef6249d24742497e6ad06a"