summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-08-10 22:54:29 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-08-12 19:22:01 +0100
commit0becc36f930969a237af7d7486fc94249b0395eb (patch)
tree057dbdc5964b77505f9ee755fed242374e49a3ff
parent459f746a198a8ae7840d783f5824fc14a44a8488 (diff)
downloadopenembedded-core-0becc36f930969a237af7d7486fc94249b0395eb.tar.gz
zip: Enable largefile support based on distro feature
The configure test tries to run a binary during build to determine largefile support, which wont work in cross-compile mode, therefore specify it when largefile DISTRO_FEATURE is on. Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
-rw-r--r--meta/recipes-extended/zip/zip_3.0.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-extended/zip/zip_3.0.bb b/meta/recipes-extended/zip/zip_3.0.bb
index 07a67b9634..d560c83464 100644
--- a/meta/recipes-extended/zip/zip_3.0.bb
+++ b/meta/recipes-extended/zip/zip_3.0.bb
@@ -29,6 +29,8 @@ CVE_CHECK_IGNORE += "CVE-2018-13410"
# Not for zip but for smart contract implementation for it
CVE_CHECK_IGNORE += "CVE-2018-13684"
+CFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', '-DLARGE_FILE_SUPPORT', '', d)}"
+
# zip.inc sets CFLAGS, but what Makefile actually uses is
# CFLAGS_NOOPT. It will also force -O3 optimization, overriding
# whatever we set.