summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2023-01-27 09:52:17 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-01-29 10:50:39 +0000
commit0d79d4883f924cef0d0ba361506ad75d441b9721 (patch)
tree13338ca27c73c32f570380b9868e90ccf01ffeb4
parent4ad1f430abe1e7706b43b36405f036fa23a4e6fd (diff)
downloadopenembedded-core-0d79d4883f924cef0d0ba361506ad75d441b9721.tar.gz
make-mod-scripts: Ensure kernel build output is deterministic
The definitions in linux-kernel-base are needed to ensure the generated headers are consistent. This was a small step that was missing from the previous changes to linux-kernel-base as both kernel-devsrc and make-mod-scripts need this information defined consistently. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb b/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb
index 9afd6714f0..38282e58f1 100644
--- a/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb
+++ b/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "https://www.yoctoproject.org/"
LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6"
-inherit kernel-arch
+inherit kernel-arch linux-kernel-base
inherit pkgconfig
PACKAGE_ARCH = "${MACHINE_ARCH}"