summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-04-29 21:18:08 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-05-02 23:21:39 +0100
commit149d84b7eba8240737a301d0fd75b69e8a767854 (patch)
tree99d32f3cbdbbb8e9b4ba027f9152d9ff3122228f
parent0672a3dae14462e590959e966fef22b6e2a2ad09 (diff)
downloadopenembedded-core-149d84b7eba8240737a301d0fd75b69e8a767854.tar.gz
libpam: Provide needed env for tst-pam_start_confdir ptest
tst-pam_start_confdir needs a file called confdir and it should reside in directory pointed by srcdir env variable, therefore copy confdir into ptest package and export srcdir before running the ptests Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/pam/libpam/run-ptest5
-rw-r--r--meta/recipes-extended/pam/libpam_1.5.1.bb1
2 files changed, 4 insertions, 2 deletions
diff --git a/meta/recipes-extended/pam/libpam/run-ptest b/meta/recipes-extended/pam/libpam/run-ptest
index 69e729ce2a..9c304aee47 100644
--- a/meta/recipes-extended/pam/libpam/run-ptest
+++ b/meta/recipes-extended/pam/libpam/run-ptest
@@ -2,9 +2,10 @@
cd tests
+export srcdir=.
+
failed=0
all=0
-
for f in tst-*; do
"./$f" > /dev/null 2>&1
case "$?" in
@@ -28,4 +29,4 @@ if [ "$failed" -eq 0 ] ; then
else
echo "$failed of $all tests failed"
fi
-
+unset srcdir
diff --git a/meta/recipes-extended/pam/libpam_1.5.1.bb b/meta/recipes-extended/pam/libpam_1.5.1.bb
index 4363e16b9b..f0c8caaac2 100644
--- a/meta/recipes-extended/pam/libpam_1.5.1.bb
+++ b/meta/recipes-extended/pam/libpam_1.5.1.bb
@@ -154,6 +154,7 @@ do_install_ptest() {
if [ ${PTEST_ENABLED} = "1" ]; then
mkdir -p ${D}${PTEST_PATH}/tests
install -m 0755 ${B}/tests/.libs/* ${D}${PTEST_PATH}/tests
+ install -m 0644 ${S}/tests/confdir ${D}${PTEST_PATH}/tests
fi
}