summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2014-02-26 15:49:16 +0200
committerSaul Wold <sgw@linux.intel.com>2014-02-28 11:32:10 +0200
commit47d824657acc55e094d5703eed68853f2048c30c (patch)
treedcd95266b2da7cc0d07aecc54d84388b5372a0c1
parent00e3acde7910a5fb1d2e6b71187f2d9283319e71 (diff)
downloadopenembedded-core-47d824657acc55e094d5703eed68853f2048c30c.tar.gz
base-files: sed installed file instead of original
When we change the ROOT_HOME the sed regex does not match if we are running the do_install() a second time, so sed the installed file and preserve the original so that the sed regex is matched correctly in the original [YOCTO #5765] Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-core/base-files/base-files_3.0.14.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/base-files/base-files_3.0.14.bb b/meta/recipes-core/base-files/base-files_3.0.14.bb
index 726e0d57ee..dbf40fa6dc 100644
--- a/meta/recipes-core/base-files/base-files_3.0.14.bb
+++ b/meta/recipes-core/base-files/base-files_3.0.14.bb
@@ -90,8 +90,8 @@ do_install () {
install -m 0644 ${WORKDIR}/fstab ${D}${sysconfdir}/fstab
install -m 0644 ${WORKDIR}/filesystems ${D}${sysconfdir}/filesystems
install -m 0644 ${WORKDIR}/usbd ${D}${sysconfdir}/default/usbd
- sed -i "s#ROOTHOME#${ROOT_HOME}#" ${WORKDIR}/profile
install -m 0644 ${WORKDIR}/profile ${D}${sysconfdir}/profile
+ sed -i 's#ROOTHOME#${ROOT_HOME}#' ${D}${sysconfdir}/profile
install -m 0644 ${WORKDIR}/shells ${D}${sysconfdir}/shells
install -m 0755 ${WORKDIR}/share/dot.profile ${D}${sysconfdir}/skel/.profile
install -m 0755 ${WORKDIR}/share/dot.bashrc ${D}${sysconfdir}/skel/.bashrc