summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2023-03-21 23:40:16 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-03-27 15:24:57 +0100
commitd06c7c0d288cafa75f14a841f9cb31dcd0714644 (patch)
tree7b8e3e8ba95498e3450ed852ecac461a34c5e049
parentf7ada8b4d003473abce5b589cc38aec1e5e5f18a (diff)
downloadopenembedded-core-d06c7c0d288cafa75f14a841f9cb31dcd0714644.tar.gz
rpm: add back find-debuginfo support
RPM upstream removed find-debuginfo and switched to use debugedit since the following commit. https://github.com/rpm-software-management/rpm/commit/04b0805a756cdd9466fb9dc717846f5bf15518cc According to https://github.com/rpm-software-management/rpm/blob/master/INSTALL, debugedit is needed by rpm. More specifically it's needed by rpmbuild to supporting generating debuginfo package when %debug_package is enabled. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
-rw-r--r--meta/recipes-devtools/rpm/rpm_4.18.0.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_4.18.0.bb b/meta/recipes-devtools/rpm/rpm_4.18.0.bb
index cdb4f227f4..7790db8b5a 100644
--- a/meta/recipes-devtools/rpm/rpm_4.18.0.bb
+++ b/meta/recipes-devtools/rpm/rpm_4.18.0.bb
@@ -134,6 +134,9 @@ do_install:append:class-target() {
}
do_install:append:class-nativesdk() {
rm -rf ${D}${SDKPATHNATIVE}/var
+ # Ensure find-debuginfo is located correctly inside SDK
+ mkdir -p ${D}${SDKPATHNATIVE}/etc/rpm
+ echo "%__find_debuginfo ${SDKPATHNATIVE}/usr/bin/find-debuginfo" >> ${D}${SDKPATHNATIVE}/etc/rpm/macros
}
do_install:append () {
@@ -159,9 +162,7 @@ FILES:${PN}-build = "\
${libdir}/librpmbuild.so.* \
${libdir}/rpm/brp-* \
${libdir}/rpm/check-* \
- ${libdir}/rpm/debugedit \
${libdir}/rpm/sepdebugcrcfix \
- ${libdir}/rpm/find-debuginfo.sh \
${libdir}/rpm/find-lang.sh \
${libdir}/rpm/*provides* \
${libdir}/rpm/*requires* \
@@ -173,6 +174,7 @@ FILES:${PN}-build = "\
${libdir}/rpm/macros.p* \
${libdir}/rpm/fileattrs/* \
"
+FILES:${PN}-build:append:class-nativesdk = " ${SDKPATHNATIVE}/etc/rpm/macros"
FILES:${PN}-sign = "\
${bindir}/rpmsign \
@@ -187,7 +189,7 @@ PACKAGES += "python3-rpm"
PROVIDES += "python3-rpm"
FILES:python3-rpm = "${PYTHON_SITEPACKAGES_DIR}/rpm/*"
-RDEPENDS:${PN}-build = "bash perl python3-core"
+RDEPENDS:${PN}-build = "bash perl python3-core debugedit"
PACKAGE_PREPROCESS_FUNCS += "rpm_package_preprocess"