aboutsummaryrefslogtreecommitdiffstats
path: root/meta/classes
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2013-08-09 17:51:30 -0500
committerPaul Eggleton <paul.eggleton@linux.intel.com>2014-03-12 19:00:34 +0000
commitc3f1bedb2494a2465db23a4d89b9f998db953f0d (patch)
treeea9dcdd68eec39da4b0bd35cd2216f4456ced811 /meta/classes
parentabf46d03eff2288715b054057ac253eca61f8a63 (diff)
downloadopenembedded-core-c3f1bedb2494a2465db23a4d89b9f998db953f0d.tar.gz
openembedded-core-c3f1bedb2494a2465db23a4d89b9f998db953f0d.tar.bz2
openembedded-core-c3f1bedb2494a2465db23a4d89b9f998db953f0d.zip
rpm: Enable compatibility with older RPM packages that have invalid platforms
Some LSB packages appear to have the platform set to '%{_target_platform}' which is not a valid platform field. This causes a failure of the type: warning: package lsb-test-core-4.1.15-1.x86_64 is intended for a %{_target_platform} platform When we detect an invalid platform, fall back and try to construct a new platform name that may be valid based on the arch and os contents of the package. (This should only ever be needed by invalid or older RPM packages.) (From OE-Core master rev: 6513fa327aeb7e9fdd313290c205917952eed226) Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes')
0 files changed, 0 insertions, 0 deletions