summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub/files
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-20 14:47:52 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-21 22:29:08 +0000
commitcb5e96e05930eaff4d679166416d6c84d6e3236b (patch)
tree9307bfdfd1d56c2e1191bc5a407972807b5218e5 /meta/recipes-bsp/grub/files
parentcd6a05e6683db7a239a9559b079a00628589263d (diff)
downloadopenembedded-core-cb5e96e05930eaff4d679166416d6c84d6e3236b.tar.gz
grub: Add second fix for determinism issue
There is a second list sorting problem in a generator script within grub, add a sort() of a list to resolve this. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/grub/files')
-rw-r--r--meta/recipes-bsp/grub/files/determinism.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/files/determinism.patch b/meta/recipes-bsp/grub/files/determinism.patch
index c4b1d3a2a8..fac80e7b54 100644
--- a/meta/recipes-bsp/grub/files/determinism.patch
+++ b/meta/recipes-bsp/grub/files/determinism.patch
@@ -4,6 +4,10 @@ depending on how awk sorts the values in the array.
Be deterministic in the output by sorting the dependencies on each line.
+Also, the output of the SOURCES lines in grub-core/Makefile.core.am, generated
+from grub-core/Makefile.core.def with gentpl.py is not deterministic due to
+missing sorting of the list used to generate it. Add such a sort.
+
Upstream-Status: Pending
Richard Purdie <richard.purdie@linuxfoundation.org>
@@ -22,3 +26,15 @@ Index: grub-2.04/grub-core/genmoddep.awk
modlist = modlist " " depmod;
inverse_dependencies[depmod] = inverse_dependencies[depmod] " " mod
depcount[mod]++
+Index: grub-2.04/gentpl.py
+===================================================================
+--- grub-2.04.orig/gentpl.py
++++ grub-2.04/gentpl.py
+@@ -568,6 +568,7 @@ def foreach_platform_value(defn, platfor
+ for group in RMAP[platform]:
+ for value in defn.find_all(group + suffix):
+ r.append(closure(value))
++ r.sort()
+ return ''.join(r)
+
+ def platform_conditional(platform, closure):