summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
diff options
context:
space:
mode:
authorLaszlo Papp <lpapp-RoXCvvDuEio@public.gmane.org>2013-08-23 10:48:10 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-26 16:26:47 +0100
commitb2d6f08ff4f03079973eab76a790bf4555e32236 (patch)
tree15cdcf42895fb5e099e92ae6ec16fc3b0f8ae34d /meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
parent18170af0d466815491f445ac7ff23906f7474d1a (diff)
downloadopenembedded-core-b2d6f08ff4f03079973eab76a790bf4555e32236.tar.gz
u-boot: update to 2013.07
Signed-off-by: Laszlo Papp <lpapp-RoXCvvDuEio@public.gmane.org> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
new file mode 100644
index 0000000000..0108e0059f
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "U-boot bootloader mkimage tool"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
+ file://README;beginline=1;endline=22;md5=78b195c11cb6ef63e6985140db7d7bab"
+SECTION = "bootloader"
+
+SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2"
+
+SRC_URI[md5sum] = "8445162690052e6afd4b8f87af2bb557"
+SRC_URI[sha256sum] = "2bbd440c1b29928d230604eac372fda5152d3ae23f52b1910c77fc5bf531250b"
+
+S = "${WORKDIR}/u-boot-${PV}"
+
+BBCLASSEXTEND = "native nativesdk"
+
+EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTLD="${LD}" HOSTLDFLAGS="${LDFLAGS}" HOSTSTRIP=true'
+
+do_compile () {
+ oe_runmake tools
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
+ ln -sf uboot-mkimage ${D}${bindir}/mkimage
+}
+