summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-31 17:12:27 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-01-01 23:14:52 +0000
commit6d9c9f7604fd32ef926726a46ae053bbab6ccb4f (patch)
tree4ea51dd846244f256b414f5cf7cc68cda8ed7078 /meta/recipes-bsp
parentbe71dd2cc16a4c0d244a76a748f08ca0d9bfeba0 (diff)
downloadopenembedded-core-6d9c9f7604fd32ef926726a46ae053bbab6ccb4f.tar.gz
grub: Further reproducibility fix
Fix the ordering in the generated unidata.c file to aid reproducibility. [YOCTO #14167] Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/grub/files/determinism.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/files/determinism.patch b/meta/recipes-bsp/grub/files/determinism.patch
index fac80e7b54..3c1f562c71 100644
--- a/meta/recipes-bsp/grub/files/determinism.patch
+++ b/meta/recipes-bsp/grub/files/determinism.patch
@@ -8,6 +8,9 @@ Also, the output of the SOURCES lines in grub-core/Makefile.core.am, generated
from grub-core/Makefile.core.def with gentpl.py is not deterministic due to
missing sorting of the list used to generate it. Add such a sort.
+Also ensure the generated unidata.c file is deterministic by sorting the
+keys of the dict.
+
Upstream-Status: Pending
Richard Purdie <richard.purdie@linuxfoundation.org>
@@ -38,3 +41,16 @@ Index: grub-2.04/gentpl.py
return ''.join(r)
def platform_conditional(platform, closure):
+Index: grub-2.04/util/import_unicode.py
+===================================================================
+--- grub-2.04.orig/util/import_unicode.py
++++ grub-2.04/util/import_unicode.py
+@@ -174,7 +174,7 @@ infile.close ()
+
+ outfile.write ("struct grub_unicode_arabic_shape grub_unicode_arabic_shapes[] = {\n ")
+
+-for x in arabicsubst:
++for x in sorted(arabicsubst):
+ try:
+ if arabicsubst[x]['join'] == "DUAL":
+ outfile.write ("{0x%x, 0x%x, 0x%x, 0x%x, 0x%x},\n " % (arabicsubst[x][0], arabicsubst[x][1], arabicsubst[x][2], arabicsubst[x][3], arabicsubst[x][4]))