summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/expat/expat_2.2.10.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-11-02 17:48:09 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-11-03 08:20:41 +0000
commitef7e5fbd460e136aa20a519372d4d69574ce73b9 (patch)
treebfaf29f770d2ab6728fdc02a7f64637b83261d00 /meta/recipes-core/expat/expat_2.2.10.bb
parent7ed1a8ee627b69d54c91d3e18d22a4679b9c10d5 (diff)
downloadopenembedded-core-ef7e5fbd460e136aa20a519372d4d69574ce73b9.tar.gz
expat: upgrade 2.2.9 -> 2.2.10
License-Update: copyright years Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/expat/expat_2.2.10.bb')
-rw-r--r--meta/recipes-core/expat/expat_2.2.10.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-core/expat/expat_2.2.10.bb b/meta/recipes-core/expat/expat_2.2.10.bb
new file mode 100644
index 0000000000..fa263775b3
--- /dev/null
+++ b/meta/recipes-core/expat/expat_2.2.10.bb
@@ -0,0 +1,27 @@
+SUMMARY = "A stream-oriented XML parser library"
+DESCRIPTION = "Expat is an XML parser library written in C. It is a stream-oriented parser in which an application registers handlers for things the parser might find in the XML document (like start tags)"
+HOMEPAGE = "http://expat.sourceforge.net/"
+SECTION = "libs"
+LICENSE = "MIT"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=9e2ce3b3c4c0f2670883a23bbd7c37a9"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/expat/expat-${PV}.tar.bz2 \
+ file://libtool-tag.patch \
+ file://run-ptest \
+ file://0001-Add-output-of-tests-result.patch \
+ "
+
+SRC_URI[sha256sum] = "b2c160f1b60e92da69de8e12333096aeb0c3bf692d41c60794de278af72135a5"
+
+EXTRA_OECMAKE_class-native += "-DEXPAT_BUILD_DOCS=OFF"
+
+RDEPENDS_${PN}-ptest += "bash"
+
+inherit cmake lib_package ptest
+
+do_install_ptest_class-target() {
+ install -m 755 ${B}/tests/* ${D}${PTEST_PATH}
+}
+
+BBCLASSEXTEND += "native nativesdk"