summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake/cmake-native_3.11.4.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-07-05 11:18:33 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-06 22:54:56 +0100
commitd942ec4ff649782d22afe49fd48839dbbfedc871 (patch)
treee4b590383a121f2cb3911bd95d58316ad93502d0 /meta/recipes-devtools/cmake/cmake-native_3.11.4.bb
parentf0ad38d02da0bbcc1534dcc99d10436675932ed9 (diff)
downloadopenembedded-core-d942ec4ff649782d22afe49fd48839dbbfedc871.tar.gz
cmake: Update 3.10.3 -> 3.11.4
This updates CMake to the current stable release and drop many backported patches in the process. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake-native_3.11.4.bb')
-rw-r--r--meta/recipes-devtools/cmake/cmake-native_3.11.4.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-devtools/cmake/cmake-native_3.11.4.bb b/meta/recipes-devtools/cmake/cmake-native_3.11.4.bb
new file mode 100644
index 0000000000..9f371e9b0c
--- /dev/null
+++ b/meta/recipes-devtools/cmake/cmake-native_3.11.4.bb
@@ -0,0 +1,36 @@
+require cmake.inc
+inherit native
+
+DEPENDS += "bzip2-replacement-native expat-native xz-native zlib-native curl-native"
+
+SRC_URI += "file://0004-Disable-use-of-ext2fs-ext2_fs.h-by-cmake-s-internal-.patch"
+
+B = "${WORKDIR}/build"
+do_configure[cleandirs] = "${B}"
+
+# Disable ccmake since we don't depend on ncurses
+CMAKE_EXTRACONF = "\
+ -DCMAKE_LIBRARY_PATH=${STAGING_LIBDIR_NATIVE} \
+ -DBUILD_CursesDialog=0 \
+ -DCMAKE_USE_SYSTEM_LIBRARIES=1 \
+ -DCMAKE_USE_SYSTEM_LIBRARY_JSONCPP=0 \
+ -DCMAKE_USE_SYSTEM_LIBRARY_LIBARCHIVE=0 \
+ -DCMAKE_USE_SYSTEM_LIBRARY_LIBUV=0 \
+ -DCMAKE_USE_SYSTEM_LIBRARY_LIBRHASH=0 \
+ -DENABLE_ACL=0 -DHAVE_ACL_LIBACL_H=0 \
+ -DHAVE_SYS_ACL_H=0 \
+"
+
+do_configure () {
+ ${S}/configure --verbose --prefix=${prefix} -- ${CMAKE_EXTRACONF}
+}
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+do_compile[progress] = "percent"