summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2019-01-24 14:57:28 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-24 22:06:14 +0000
commit815056cb595c0f57b4d8867387420fe3bb28bdb2 (patch)
tree07bb3ed58f844cc3634d0b54fa6c66bf9b0ffe52 /meta/recipes-devtools/cmake
parent78a24b3a1eae04e5f4744f320e4ccbb8bfe17b9a (diff)
downloadopenembedded-core-815056cb595c0f57b4d8867387420fe3bb28bdb2.tar.gz
cmake-native: Add --enable-ccache to configure options
cmake-native requires --enable-ccache to enable ccache, target recipe doesn't need this since it is already handled by cmake.bbclass. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/cmake')
-rw-r--r--meta/recipes-devtools/cmake/cmake-native_3.12.2.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/cmake/cmake-native_3.12.2.bb b/meta/recipes-devtools/cmake/cmake-native_3.12.2.bb
index 2f4ecc4f4c..fedcf3d4bd 100644
--- a/meta/recipes-devtools/cmake/cmake-native_3.12.2.bb
+++ b/meta/recipes-devtools/cmake/cmake-native_3.12.2.bb
@@ -29,6 +29,7 @@ CMAKE_EXTRACONF = "\
do_configure () {
${S}/configure --verbose --prefix=${prefix} \
${@oe.utils.parallel_make_argument(d, '--parallel=%d')} \
+ ${@bb.utils.contains('CCACHE', 'ccache ', '--enable-ccache', '', d)} \
-- ${CMAKE_EXTRACONF}
}