summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-07-23 17:47:43 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-09 09:24:02 +0100
commit0505075ae8d339ba097aebb82b4d0ae62f87c0a9 (patch)
tree6ac6ad2b28dc62bcf392ceef0e127805433b4978 /meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb
parent65e644368fc9c294af96906528ee0cf30305e0a6 (diff)
downloadopenembedded-core-0505075ae8d339ba097aebb82b4d0ae62f87c0a9.tar.gz
ossp-uuid, libffi, libgcrypt: Pass --tag=CC option to libtool
libtool tries to guess the --tag value based on CC/CXX environment variables and the compile commandline generated by makefiles. This heuristics however fails when we construct CC variables in OE and add security flags to it, especially -fPIE -pie which are added by external compilers e.g. clang particularly. It fails because libtool removed PIE flags from compiler cmdline intelligently if it figures out that its building a library, which means that the CC variable passed from cmdline does not match with the compiler cmdline constructed by libtool and we end up with errors like | arm-bec-linux-musleabi-libtool: compile: unable to infer tagged configuration | arm-bec-linux-musleabi-libtool: error: specify a tag with '--tag' This works with internal gcc toolchain because we configure gcc for PIE when hardening is selected and dont pass -fPIE -pie options explicitly but this is not an option for clang, and some external gcc toolchains using older gcc This patch adds the --tag option to help libtool set correct tags in packages where it cant get it right via its heuristics Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb')
-rw-r--r--meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb b/meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb
index 85a1bcf5ca..5d9ca790e9 100644
--- a/meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb
+++ b/meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb
@@ -27,6 +27,7 @@ SRC_URI = "http://snapshot.debian.org/archive/debian/20160728T043443Z/pool/main/
file://uuid-nostrip.patch \
file://install-pc.patch \
file://ldflags.patch \
+ file://libtool-tag.patch \
"
SRC_URI[md5sum] = "5db0d43a9022a6ebbbc25337ae28942f"
SRC_URI[sha256sum] = "11a615225baa5f8bb686824423f50e4427acd3f70d394765bdff32801f0fd5b0"
@@ -37,6 +38,7 @@ inherit autotools update-alternatives
EXTRA_OECONF = "--without-dce --without-cxx --without-perl --without-perl-compat --without-php --without-pgsql"
EXTRA_OECONF = "--includedir=${includedir}/ossp"
+EXTRA_OEMAKE_class-target = "LIBTOOLFLAGS='--tag=CC'"
do_configure_prepend() {
# This package has a completely custom aclocal.m4, which should be acinclude.m4.