summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-hypothesis_6.54.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-08-08 08:42:27 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-08-10 08:20:13 +0100
commitd552aae12ef88e860c19619139cfea5d1771f2f3 (patch)
tree908a0aeb7970952de636110c32df5bac0b436e62 /meta/recipes-devtools/python/python3-hypothesis_6.54.1.bb
parentbba47263174a7efba90a710e8ff2d1ae2b8f9bc2 (diff)
downloadopenembedded-core-d552aae12ef88e860c19619139cfea5d1771f2f3.tar.gz
python3-hypothesis: upgrade 6.50.1 -> 6.54.1
Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-hypothesis_6.54.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-hypothesis_6.54.1.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-hypothesis_6.54.1.bb b/meta/recipes-devtools/python/python3-hypothesis_6.54.1.bb
new file mode 100644
index 0000000000..afcd5e64ef
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-hypothesis_6.54.1.bb
@@ -0,0 +1,38 @@
+SUMMARY = "A library for property-based testing"
+HOMEPAGE = "https://github.com/HypothesisWorks/hypothesis/tree/master/hypothesis-python"
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4ee62c16ebd0f4f99d906f36b7de8c3c"
+
+PYPI_PACKAGE = "hypothesis"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+ file://test_binary_search.py \
+ file://test_rle.py \
+ "
+
+SRC_URI[sha256sum] = "de63c34309181875e71d0f5d1c1051c9320a1fe0517ea6733af8cedf818191f4"
+
+RDEPENDS:${PN} += " \
+ python3-attrs \
+ python3-compression \
+ python3-core \
+ python3-json \
+ python3-sortedcontainers \
+ python3-statistics \
+ python3-unittest \
+ "
+
+RDEPENDS:${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+ "
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/examples
+ install -m 0755 ${WORKDIR}/test_binary_search.py ${D}${PTEST_PATH}/examples/
+ install -m 0755 ${WORKDIR}/test_rle.py ${D}${PTEST_PATH}/examples/
+}
+
+BBCLASSEXTEND = "native nativesdk"