summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3/makerace.patch
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-10-27 22:16:11 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-10-29 16:23:27 +0100
commitf10cdc155e47af5627ee999c57e1d083f9382a91 (patch)
tree0925aa13affb42a372c1624f91a1c1389391b322 /meta/recipes-devtools/python/python3/makerace.patch
parentb5001af5c711a373bd2f1ea108c8b597dd40faca (diff)
downloadopenembedded-core-f10cdc155e47af5627ee999c57e1d083f9382a91.tar.gz
python3: update 3.10.6 -> 3.11.0
The semaphore fix has landed and is available from 3.11 onwards: https://github.com/python/cpython/commit/1ee0f94d16f150356a4b9b0a39d44ba1d2d5b9fc Drop 0001-Mitigate-the-race-condition-in-testSockName.patch as it is merged upstream. Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Diffstat (limited to 'meta/recipes-devtools/python/python3/makerace.patch')
-rw-r--r--meta/recipes-devtools/python/python3/makerace.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta/recipes-devtools/python/python3/makerace.patch b/meta/recipes-devtools/python/python3/makerace.patch
index 2c06784ffc..979fc9dc36 100644
--- a/meta/recipes-devtools/python/python3/makerace.patch
+++ b/meta/recipes-devtools/python/python3/makerace.patch
@@ -1,4 +1,4 @@
-From 7cc02dfa593d1350a689d64a7a6f2dc6478afe24 Mon Sep 17 00:00:00 2001
+From 4f52aaf2a548b3356c6f1369c62b11335dc27464 Mon Sep 17 00:00:00 2001
From: Richard Purdie <richard.purdie@linuxfoundation.org>
Date: Tue, 13 Jul 2021 23:19:29 +0100
Subject: [PATCH] python3: Fix make race
@@ -18,15 +18,15 @@ Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile.pre.in b/Makefile.pre.in
-index 5e13ba2..026bffd 100644
+index 7558f0c..8cec819 100644
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
-@@ -1527,7 +1527,7 @@ TESTSUBDIRS= ctypes/test \
+@@ -2005,7 +2005,7 @@ TESTSUBDIRS= ctypes/test \
unittest/test unittest/test/testmock
TEST_MODULES=@TEST_MODULES@
--libinstall: build_all $(srcdir)/Modules/xxmodule.c
-+libinstall: build_all $(srcdir)/Modules/xxmodule.c libainstall
+-libinstall: all $(srcdir)/Modules/xxmodule.c
++libinstall: all $(srcdir)/Modules/xxmodule.c libainstall
@for i in $(SCRIPTDIR) $(LIBDEST); \
do \
if test ! -d $(DESTDIR)$$i; then \