summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3_3.3.3.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-01-12 18:55:19 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-01-16 23:06:46 +0000
commitaea42f59c8331c4d5944f698453bfd663aa0c59d (patch)
treeedc9e0e03bb95d592a0ee94d2d3002e165c03c76 /meta/recipes-devtools/python/python3_3.3.3.bb
parentaf92ac8ef84a689a9c22dce6b06e5e813dce88dc (diff)
downloadopenembedded-core-aea42f59c8331c4d5944f698453bfd663aa0c59d.tar.gz
python: fix B != S
And bump PR to avoid: gcc: error: Parser/tokenizer_pgen.o: No such file or directory gcc: error: Parser/printgrammar.o: No such file or directory gcc: error: Parser/pgenmain.o: No such file or directory Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta/recipes-devtools/python/python3_3.3.3.bb')
-rw-r--r--meta/recipes-devtools/python/python3_3.3.3.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-devtools/python/python3_3.3.3.bb b/meta/recipes-devtools/python/python3_3.3.3.bb
index 2c1f63f5b8..efa98c09fa 100644
--- a/meta/recipes-devtools/python/python3_3.3.3.bb
+++ b/meta/recipes-devtools/python/python3_3.3.3.bb
@@ -76,7 +76,7 @@ do_configure_prepend() {
do_compile() {
# regenerate platform specific files, because they depend on system headers
- cd Lib/plat-linux*
+ cd ${S}/Lib/plat-linux*
include=${STAGING_INCDIR} ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
${S}/Tools/scripts/h2py.py -i '(u_long)' \
${STAGING_INCDIR}/dlfcn.h \
@@ -108,7 +108,7 @@ do_compile() {
install -m 0644 Makefile Makefile.sysroot
export CROSS_COMPILE="${TARGET_PREFIX}"
- export PYTHONBUILDDIR="${S}"
+ export PYTHONBUILDDIR="${B}"
oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/python3-native/pgen \
HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python3-native/python3 \
STAGING_LIBDIR=${STAGING_LIBDIR} \
@@ -136,7 +136,7 @@ do_install() {
install -m 0644 Makefile.orig Makefile
export CROSS_COMPILE="${TARGET_PREFIX}"
- export PYTHONBUILDDIR="${S}"
+ export PYTHONBUILDDIR="${B}"
install -d ${D}${libdir}/pkgconfig
install -d ${D}${libdir}/python${PYTHON_MAJMIN}/config