aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2013-06-19 06:33:07 -0400
committerPaul Eggleton <paul.eggleton@linux.intel.com>2013-07-08 10:30:20 +0100
commit03afd1cde0c308c079b7e10cbf6424e28a5c4a75 (patch)
treef23340e34b1a2cbb0243b49997ee541ba5f362a4 /meta/recipes-devtools
parentabf0d8d471c90670e76610c91469b139bcc7ea82 (diff)
downloadopenembedded-core-03afd1cde0c308c079b7e10cbf6424e28a5c4a75.tar.gz
python-pygobject: disable parallel install
The installation of __glib.so is invoked by install-data-am target which are generated by automake. installing libpyglib-2.0-python is invoked by install-exec-am. "make install" will firstly install libpyglib-2.0-python, then install __glib.so, the sequence should not be broken, since _glib.so has dependence on libpyglib-2.0-python. But when enable parallel install, the sequence maybe break then installation fails with: "/usr/bin/ld: cannot find -lpyglib-2.0-python" Disable parallel install to fix this issue. (From OE-Core master rev: e87a0c81c77d11f892a34c2d14ffbeb4342d32dd) Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python-pygobject_2.27.91.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-pygobject_2.27.91.bb b/meta/recipes-devtools/python/python-pygobject_2.27.91.bb
index 4381107ae5..110d1af25b 100644
--- a/meta/recipes-devtools/python/python-pygobject_2.27.91.bb
+++ b/meta/recipes-devtools/python/python-pygobject_2.27.91.bb
@@ -20,6 +20,8 @@ S = "${WORKDIR}/pygobject-${PV}"
FILESPATH = "${FILE_DIRNAME}/python-pygobject:${FILE_DIRNAME}/files"
EXTRA_OECONF += "--disable-introspection"
+PARALLEL_MAKEINST = ""
+
inherit autotools distutils-base pkgconfig
# necessary to let the call for python-config succeed