summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-12 12:51:51 +0100
committerAnuj Mittal <anuj.mittal@intel.com>2021-11-01 23:18:14 +0800
commitb06105ec1a33bb37d42a10222e07b7f8eb69baff (patch)
tree1e1e8efc53e31543f07e8a1670de5ae219d497c2 /meta/recipes-devtools
parentd0a81a8aea047746d55e77777ee3d32dedbdf087 (diff)
downloadopenembedded-core-b06105ec1a33bb37d42a10222e07b7f8eb69baff.tar.gz
bootchart2: Don't compile python modules
"make install" may attempt to compile the python modules but it uses the host python and host paths which means the binaries are not reproducbile. Make things consistent. If anyone needs compiling, it will beed to be fixed to be cross compile compatible. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 1189f95e05c80286e009e1ab46a603ee5b7ca239) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb b/meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb
index f6a77b4606..d5beaecd0e 100644
--- a/meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb
+++ b/meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb
@@ -99,6 +99,10 @@ SRC_URI = "git://github.com/xrmx/bootchart.git \
S = "${WORKDIR}/git"
SRCREV = "868a2afab9da34f32c007d773b77253c93104636"
+# remove at next version upgrade or when output changes
+PR = "r1"
+HASHEQUIV_HASH_VERSION .= ".1"
+
inherit systemd update-rc.d python3native update-alternatives
ALTERNATIVE_${PN} = "bootchartd"
@@ -131,7 +135,7 @@ do_install () {
export PKGLIBDIR="${base_libdir}/bootchart"
export SYSTEMD_UNIT_DIR="${systemd_unitdir}/system"
- oe_runmake install
+ oe_runmake install NO_PYTHON_COMPILE=1
install -d ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/bootchartd_stop.sh ${D}${sysconfdir}/init.d