summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2020-10-31 10:23:33 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-18 23:27:20 +0000
commit765772631d6f03621d1f11a79b1e3f1a464111cb (patch)
treee3381f348762228e0e1ea78998715f6442f07a8b /meta/recipes-devtools
parentdeaf4cd5af29207dc06203fbaab9bd7ab90ac789 (diff)
downloadopenembedded-core-765772631d6f03621d1f11a79b1e3f1a464111cb.tar.gz
python3-sphinx-rtd-theme: Add new recipe
Needed for building sphinx docs Based on a patch from Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python3-sphinx-rtd-theme_0.5.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-sphinx-rtd-theme_0.5.0.bb b/meta/recipes-devtools/python/python3-sphinx-rtd-theme_0.5.0.bb
new file mode 100644
index 0000000000..4a43b595aa
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-sphinx-rtd-theme_0.5.0.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Sphinx Theme reader"
+HOMEPAGE = "https://github.com/readthedocs/sphinx_rtd_theme"
+SECTION = "devel/python"
+LICENSE = "MIT & OFL-1.1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a1db7d4ef426c2935227264e1d4ae8f9 \
+ file://OFL-License.txt;md5=4534c22e0147eadb6828bd9fe86d4868 \
+ file://Apache-License-2.0.txt;md5=8a75796f0ef19c3f601d69857f5a9a5b"
+
+DEPENDS = "python3-sphinx"
+
+PYPI_PACKAGE = "sphinx_rtd_theme"
+
+SRC_URI[sha256sum] = "22c795ba2832a169ca301cd0a083f7a434e09c538c70beb42782c073651b707d"
+
+inherit setuptools3 pypi
+
+#Fake out the setup scipt
+export CI = "True"
+export TOX_ENV_NAME = "True"
+
+BBCLASSEXTEND = "native nativesdk"