summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-28 11:24:01 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-28 13:54:21 +0000
commitf2879f3831ac86018e9526e34815f99eafe1ba82 (patch)
tree450c5b030ad757f7da7a809bb056a6c198d0d36a /meta/recipes-devtools
parent56301698a55bcbab4272b273fd98ce4de84cbfac (diff)
downloadopenembedded-core-f2879f3831ac86018e9526e34815f99eafe1ba82.tar.gz
python3: Fix QA warning
Addresses the warning: WARNING: QA Issue: python3-native: configure was passed unrecognised options: --with-wctype-functions since this option was removed in python 3. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python3-native_3.3.3.bb3
-rw-r--r--meta/recipes-devtools/python/python3_3.3.3.bb3
2 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-native_3.3.3.bb b/meta/recipes-devtools/python/python3-native_3.3.3.bb
index 97bf3b5297..534dbec180 100644
--- a/meta/recipes-devtools/python/python3-native_3.3.3.bb
+++ b/meta/recipes-devtools/python/python3-native_3.3.3.bb
@@ -51,6 +51,9 @@ EXTRA_OEMAKE = '\
ARCH=${TARGET_ARCH} \
'
+# No ctypes option for python 3
+PYTHONLSBOPTS = ""
+
do_configure_prepend() {
autoreconf --verbose --install --force --exclude=autopoint Modules/_ctypes/libffi || bbnote "_ctypes failed to autoreconf"
}
diff --git a/meta/recipes-devtools/python/python3_3.3.3.bb b/meta/recipes-devtools/python/python3_3.3.3.bb
index 5d1ef5b314..0631fd9873 100644
--- a/meta/recipes-devtools/python/python3_3.3.3.bb
+++ b/meta/recipes-devtools/python/python3_3.3.3.bb
@@ -60,6 +60,9 @@ TARGET_CC_ARCH_append_armv7a = " -D__SOFTFP__"
TARGET_CC_ARCH += "-DNDEBUG -fno-inline"
EXTRA_OEMAKE += "CROSS_COMPILE=yes"
+# No ctypes option for python 3
+PYTHONLSBOPTS = ""
+
do_configure_prepend() {
rm -f ${S}/Makefile.orig
autoreconf -Wcross --verbose --install --force --exclude=autopoint Modules/_ctypes/libffi || bbnote "_ctypes failed to autoreconf"