aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tzcode/tzcode-native_2017c.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2017-11-03 12:54:35 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-03 17:07:17 +0000
commit0b1f73a77f8d01960f1fc1bf073d8c1f9a839fff (patch)
treecf81eb8ea572000b159cf650d04830abc35e8acc /meta/recipes-extended/tzcode/tzcode-native_2017c.bb
parentbf0103c7fce3d507e147e1f2381c402fca123364 (diff)
downloadopenembedded-core-0b1f73a77f8d01960f1fc1bf073d8c1f9a839fff.tar.gz
tzcode-native: update to 2017c
LICENSE changes do to rewording https://github.com/eggert/tz/commit/7097a652778d35acf747d14f8bf7b3ced479bbc0#diff-9879d6db96fd29134fc802214163b95a Backported to fixes from upstream too. Changes to code zic and the reference runtime now reject multiple leap seconds within 28 days of each other, or leap seconds before the Epoch. As a result, support for double leap seconds, which was obsolescent and undocumented, has been removed. Double leap seconds were an error in the C89 standard; they have never existed in civil timekeeping. (Thanks to Robert Elz and Bradley White for noticing glitches in the code that uncovered this problem.) zic now warns about use of the obsolescent and undocumented -y option, and about use of the obsolescent TYPE field of Rule lines. zic now allows unambiguous abbreviations like "Sa" and "Su" for weekdays; formerly it rejected them due to a bug. Conversely, zic no longer considers non-prefixes to be abbreviations; for example, it no longer accepts "lF" as an abbreviation for "lastFriday". Also, zic warns about the undocumented usage with a "last-" prefix, e.g., "last-Fri". Similarly, zic now accepts the unambiguous abbreviation "L" for "Link" in ordinary context and for "Leap" in leap-second context. Conversely, zic no longer accepts non-prefixes such as "La" as abbreviations for words like "Leap". zic no longer accepts leap second lines in ordinary input, or ordinary lines in leap second input. Formerly, zic sometimes warned about this undocumented usage and handled it incorrectly. The new macro HAVE_TZNAME governs whether the tzname external variable is exported, instead of USG_COMPAT. USG_COMPAT now governs only the external variables "timezone" and "daylight". This change is needed because the three variables are not in the same category: although POSIX requires tzname, it specifies the other two variables as optional. Also, USG_COMPAT is now 1 or 0: if not defined, the code attempts to guess it from other macros. localtime.c and difftime.c no longer require stdio.h, and .c files other than zic.c no longer require sys/wait.h. zdump.c no longer assumes snprintf. (Reported by Jonathan Leffler.) Calculation of time_t extrema works around a bug in GCC 4.8.4 (Reported by Stan Shebs and Joseph Myers.) zic.c no longer mistranslates formats of line numbers in non-English locales. (Problem reported by Benno Schulenberg.) Several minor changes have been made to the code to make it a bit easier to port to MS-Windows and Solaris. (Thanks to Kees Dekker for reporting the problems.) Changes to documentation and commentary The two new files 'theory.html' and 'calendars' contain the contents of the removed file 'Theory'. The goal is to document tzdb theory more accessibly. The zic man page now documents abbreviation rules. tz-link.htm now covers how to apply tzdata changes to clients. (Thanks to Jorge Fábregas for the AIX link.) It also mentions MySQL. The leap-seconds.list URL has been updated to something that is more reliable for tzdb. (Thanks to Tim Parenti and Brian Inglis.) Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 74af497f8d6b4e28d97c0f2cdb4ece90c2a6b8b5) Signed-off-by: Armin Kuster <akuster808@gmail.com> (cherry picked from commit 12a538bbbc8d04e875f81bd65e9754d749273aac)
Diffstat (limited to 'meta/recipes-extended/tzcode/tzcode-native_2017c.bb')
-rw-r--r--meta/recipes-extended/tzcode/tzcode-native_2017c.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-extended/tzcode/tzcode-native_2017c.bb b/meta/recipes-extended/tzcode/tzcode-native_2017c.bb
new file mode 100644
index 0000000000..aeaef726bc
--- /dev/null
+++ b/meta/recipes-extended/tzcode/tzcode-native_2017c.bb
@@ -0,0 +1,31 @@
+# note that we allow for us to use data later than our code version
+#
+SUMMARY = "tzcode, timezone zoneinfo utils -- zic, zdump, tzselect"
+LICENSE = "PD & BSD & BSD-3-Clause"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c679c9d6b02bc2757b3eaf8f53c43fba"
+
+SRC_URI =" http://www.iana.org/time-zones/repository/releases/tzcode${PV}.tar.gz;name=tzcode \
+ http://www.iana.org/time-zones/repository/releases/tzdata${PV}.tar.gz;name=tzdata \
+ file://0001-Fix-Makefile-quoting-bug.patch \
+ file://0002-Port-zdump-to-C90-snprintf.patch"
+
+UPSTREAM_CHECK_URI = "http://www.iana.org/time-zones"
+
+SRC_URI[tzcode.md5sum] = "2fe6986231db5182c61d565021a0cd7b"
+SRC_URI[tzcode.sha256sum] = "81e8b4bc23e60906640c266bbff3789661e22f0fa29fe61b96ec7c2816c079b7"
+SRC_URI[tzdata.md5sum] = "1e751e7e08f8b68530674f04619d894d"
+SRC_URI[tzdata.sha256sum] = "d6543f92a929826318e2f44ff3a7611ce5f565a43e10250b42599d0ba4cbd90b"
+
+S = "${WORKDIR}"
+
+inherit native
+
+EXTRA_OEMAKE += "cc='${CC}'"
+
+do_install () {
+ install -d ${D}${bindir}/
+ install -m 755 zic ${D}${bindir}/
+ install -m 755 zdump ${D}${bindir}/
+ install -m 755 tzselect ${D}${bindir}/
+}