aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-07-21 15:34:21 +0200
committerPaul Eggleton <paul.eggleton@linux.intel.com>2013-08-16 10:39:47 +0100
commit8eba15cb34c5ce9712968de04f849d5fa3e6a1db (patch)
treeb1a202296d3c7bb921e2f49eff259b79a6ae0ef7 /meta/recipes-extended
parent85d1c85af0422b3dbfce5630e2901607684d4930 (diff)
downloadopenembedded-core-8eba15cb34c5ce9712968de04f849d5fa3e6a1db.tar.gz
minicom: add configure option and PACKAGECONFIG for lockdev
* it's autodetected from sysroot * add PACKAGECONFIG to make it deterministic (From OE-Core master rev: a886f2f78c847df9d6fbbcbd3c4ad3581b928e2f) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/minicom/minicom-2.6.2/allow.to.disable.lockdev.patch21
-rw-r--r--meta/recipes-extended/minicom/minicom_2.6.2.bb7
2 files changed, 27 insertions, 1 deletions
diff --git a/meta/recipes-extended/minicom/minicom-2.6.2/allow.to.disable.lockdev.patch b/meta/recipes-extended/minicom/minicom-2.6.2/allow.to.disable.lockdev.patch
new file mode 100644
index 0000000000..f5c08896ff
--- /dev/null
+++ b/meta/recipes-extended/minicom/minicom-2.6.2/allow.to.disable.lockdev.patch
@@ -0,0 +1,21 @@
+Upstream-Status: Pending
+
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+
+--- a/configure.in 2013-02-06 18:18:13.000000000 +0100
++++ b/configure.in 2013-07-21 15:31:27.614828894 +0200
+@@ -40,7 +40,13 @@
+ fi
+
+ PKG_PROG_PKG_CONFIG
+-if test -n "$PKG_CONFIG"; then
++
++AC_ARG_ENABLE([lockdev],
++ AS_HELP_STRING([--enable-lockdev],
++ [Enable lockdev support (def: enabled)]),
++ [], [enable_lockdev="yes"])
++
++if test -n "$PKG_CONFIG" && test "x$enable_lockdev" = xyes; then
+ PKG_CHECK_MODULES([LOCKDEV], [lockdev], AC_DEFINE([HAVE_LOCKDEV],[1],[Define if you have lockdev]),[:])
+ fi
+
diff --git a/meta/recipes-extended/minicom/minicom_2.6.2.bb b/meta/recipes-extended/minicom/minicom_2.6.2.bb
index 0d65e80f51..558867d1d1 100644
--- a/meta/recipes-extended/minicom/minicom_2.6.2.bb
+++ b/meta/recipes-extended/minicom/minicom_2.6.2.bb
@@ -8,11 +8,16 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=420477abc567404debca0a2a1cb6b645 \
PR = "r0"
-SRC_URI = "http://alioth.debian.org/frs/download.php/3869/minicom-${PV}.tar.gz"
+SRC_URI = "http://alioth.debian.org/frs/download.php/3869/minicom-${PV}.tar.gz \
+ file://allow.to.disable.lockdev.patch \
+"
SRC_URI[md5sum] = "203c56c4b447f45e2301b0cc4e83da3c"
SRC_URI[sha256sum] = "f3cf215f7914ffa5528e398962176102ad74df27ba38958142f56aa6d15c9168"
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[lockdev] = "--enable-lockdev,--disable-lockdev,lockdev"
+
inherit autotools gettext
do_install() {