summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorAlex Stewart <alex.stewart@ni.com>2022-02-22 17:44:57 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-02-25 12:39:00 +0000
commit7d688f0ece8fa7e3118cde0c79bbcc56048a2bb5 (patch)
treecd76a143689d38ae54dc69e204f7d061384980f6 /meta/recipes-extended
parent621623a5421172fddda1c31edaaba269a4b83e1a (diff)
downloadopenembedded-core-7d688f0ece8fa7e3118cde0c79bbcc56048a2bb5.tar.gz
sudo: add /etc/sudoers to sudo-lib conffiles
When OE-core commit 788c95c3bb8ede0d3d6a8f125743ac47c0b3f00e created the `sudo-lib` subpackage, /etc/sudoers was moved from `sudo` to `sudo-lib`. The commit didn't update the `CONFFILES:${PN}` assignment in sudo.inc, however. So the `sudo` base package continued to advertise conffile ownership of /etc/sudoers, though it did not contain it. Move the CONFFILES assignment to the sudo.bb file, since it is packaging-related. Change the package owner to the `sudo-lib` subpackage, since it is the rightful file-owner. Signed-off-by: Alex Stewart <alex.stewart@ni.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/sudo/sudo.inc2
-rw-r--r--meta/recipes-extended/sudo/sudo_1.9.9.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-extended/sudo/sudo.inc b/meta/recipes-extended/sudo/sudo.inc
index 05d030c2e9..8947c46129 100644
--- a/meta/recipes-extended/sudo/sudo.inc
+++ b/meta/recipes-extended/sudo/sudo.inc
@@ -24,8 +24,6 @@ PACKAGECONFIG ??= ""
PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib"
PACKAGECONFIG[pam-wheel] = ",,,pam-plugin-wheel"
-CONFFILES:${PN} = "${sysconfdir}/sudoers"
-
EXTRA_OECONF = "--with-editor=${base_bindir}/vi --with-env-editor"
EXTRA_OECONF:append:libc-musl = " --disable-hardening "
diff --git a/meta/recipes-extended/sudo/sudo_1.9.9.bb b/meta/recipes-extended/sudo/sudo_1.9.9.bb
index f1c0339bb3..d7d71bb364 100644
--- a/meta/recipes-extended/sudo/sudo_1.9.9.bb
+++ b/meta/recipes-extended/sudo/sudo_1.9.9.bb
@@ -48,6 +48,8 @@ do_install:append () {
FILES:${PN}-dev += "${libdir}/${BPN}/lib*${SOLIBSDEV} ${libdir}/${BPN}/*.la \
${libdir}/lib*${SOLIBSDEV} ${libdir}/*.la"
+CONFFILES:${PN}-lib = "${sysconfdir}/sudoers"
+
SUDO_PACKAGES = "${PN}-sudo\
${PN}-lib"