aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gnome
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-01-27 13:27:56 -0800
committerSaul Wold <sgw@linux.intel.com>2012-02-07 14:37:15 -0800
commit7eae02f47a08587cf5be3d39df0184cf346cbaea (patch)
tree11392b7a0033443f8067726a79942c60eb561f3d /meta/recipes-gnome/gnome
parentcfd84a05581e068d705b0804829c4833a06bffa6 (diff)
downloadopenembedded-core-7eae02f47a08587cf5be3d39df0184cf346cbaea.tar.gz
gconf,consolekit: Avoid polkit when compiling with uclibc
polkit uses netdb functionality from glibc which is not available in uclibc therefore we avoid polkit when compiling for uclibc systems. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-gnome/gnome')
-rw-r--r--meta/recipes-gnome/gnome/gconf_3.2.3.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta/recipes-gnome/gnome/gconf_3.2.3.bb b/meta/recipes-gnome/gnome/gconf_3.2.3.bb
index 412f01c86f..a0b8d0c632 100644
--- a/meta/recipes-gnome/gnome/gconf_3.2.3.bb
+++ b/meta/recipes-gnome/gnome/gconf_3.2.3.bb
@@ -3,10 +3,13 @@ SECTION = "x11/gnome"
LICENSE = "LGPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
-DEPENDS = "glib-2.0 gtk+ dbus dbus-glib libxml2 intltool-native polkit"
+POLKIT = "polkit"
+POLKIT_libc-uclibc = ""
+
+DEPENDS = "glib-2.0 gtk+ dbus dbus-glib libxml2 intltool-native ${POLKIT}"
DEPENDS_virtclass-native = "glib-2.0-native dbus-native dbus-glib-native libxml2-native intltool-native gnome-common-native"
-PR = "r5"
+PR = "r6"
inherit gnomebase
@@ -21,6 +24,8 @@ S = "${WORKDIR}/GConf-${PV}"
POLKIT_OECONF = "--enable-defaults-service"
POLKIT_OECONF_virtclass-native = "--disable-defaults-service"
+POLKIT_OECONF_libc-uclibc = "--disable-default-service"
+
GTKOECONF = "--with-gtk=2.0 --enable-gtk"
GTKOECONF_virtclass-native = "--disable-gtk"
EXTRA_OECONF = "--disable-gtk-doc --enable-shared --disable-static --enable-debug=yes \