summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/clutter
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-03-08 20:17:39 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-09 09:16:01 -0800
commit385d26b7f0aeb6085bd7d96332b760057bd24537 (patch)
tree9ab9e10189582f4182bef5f2ba1f49640d12cb53 /meta/recipes-graphics/clutter
parent320f03b8492e5259c45e7c59b62571d5a827ee59 (diff)
downloadopenembedded-core-385d26b7f0aeb6085bd7d96332b760057bd24537.tar.gz
clutter: refresh patches
The patch tool will apply patches by default with "fuzz", which is where if the hunk context isn't present but what is there is close enough, it will force the patch in. Whilst this is useful when there's just whitespace changes, when applied to source it is possible for a patch applied with fuzz to produce broken code which still compiles (see #10450). This is obviously bad. We'd like to eventually have do_patch() rejecting any fuzz on these grounds. For that to be realistic the existing patches with fuzz need to be rebased and reviewed. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics/clutter')
-rw-r--r--meta/recipes-graphics/clutter/clutter-1.0/install-examples.patch11
1 files changed, 6 insertions, 5 deletions
diff --git a/meta/recipes-graphics/clutter/clutter-1.0/install-examples.patch b/meta/recipes-graphics/clutter/clutter-1.0/install-examples.patch
index 3b6a70ef0a..ce9ab3a248 100644
--- a/meta/recipes-graphics/clutter/clutter-1.0/install-examples.patch
+++ b/meta/recipes-graphics/clutter/clutter-1.0/install-examples.patch
@@ -3,11 +3,11 @@ Install the examples to $libdir/clutter/.
Signed-off-by: Ross Burton <ross.burton@intel.com>
Upstream-Status: Inappropriate
-diff --git a/examples/Makefile.am b/examples/Makefile.am
-index 4b9b449..232cd19 100644
---- a/examples/Makefile.am
-+++ b/examples/Makefile.am
-@@ -38,6 +38,7 @@ AM_CPPFLAGS = \
+Index: clutter-1.26.2/examples/Makefile.am
+===================================================================
+--- clutter-1.26.2.orig/examples/Makefile.am
++++ clutter-1.26.2/examples/Makefile.am
+@@ -33,7 +33,8 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/clutter \
-I$(top_builddir)/clutter
@@ -16,3 +16,4 @@ index 4b9b449..232cd19 100644
+example_PROGRAMS = $(all_examples)
EXTRA_DIST = redhand.png
+