summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libsdl
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2012-02-15 19:45:38 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-21 17:53:00 +0000
commitd2c96e22de19a649ff7121e5ea0f95797abba93a (patch)
treeca8ff242d966c5ce48ae94002a8efab1d41a2ede /meta/recipes-graphics/libsdl
parent38d74ee1fe6f28ec4d7db79f550c7d2830d922fb (diff)
downloadopenembedded-core-d2c96e22de19a649ff7121e5ea0f95797abba93a.tar.gz
libsdl: add fix for new _XGetRequest symbol backported to libx11
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta/recipes-graphics/libsdl')
-rw-r--r--meta/recipes-graphics/libsdl/libsdl-1.2.14/add.XGetRequest.symbol.patch70
-rw-r--r--meta/recipes-graphics/libsdl/libsdl_1.2.14.bb3
2 files changed, 72 insertions, 1 deletions
diff --git a/meta/recipes-graphics/libsdl/libsdl-1.2.14/add.XGetRequest.symbol.patch b/meta/recipes-graphics/libsdl/libsdl-1.2.14/add.XGetRequest.symbol.patch
new file mode 100644
index 0000000000..7bab177749
--- /dev/null
+++ b/meta/recipes-graphics/libsdl/libsdl-1.2.14/add.XGetRequest.symbol.patch
@@ -0,0 +1,70 @@
+_XGetRequest API was backported to libx11-1.4.4 in:
+http://git.openembedded.org/openembedded-core/commit/?id=e08604800fe1cb8f240f53c147ceb4ee08a29b91
+
+This breaks e.g. libsdl-image build with:
+| /OE/shr-core/tmp-eglibc/sysroots/qemux86-64/usr/lib/libSDL.so: undefined reference to `_XGetRequest'
+
+For details see: https://bugzilla.redhat.com/show_bug.cgi?id=782251
+
+Upstream-Status: Accepted
+
+@@ -, +, @@
+ added.
+ src/video/x11/SDL_x11dyn.c | 24 ++++++++++++++++++++++++
+ src/video/x11/SDL_x11sym.h | 6 ++++++
+ 2 files changed, 30 insertions(+), 0 deletions(-)
+--- a/src/video/x11/SDL_x11dyn.c
++++ a/src/video/x11/SDL_x11dyn.c
+@@ -109,6 +109,21 @@ char *(*pXGetICValues)(XIC, ...) = NULL;
+ #undef SDL_X11_SYM
+
+
++static void *SDL_XGetRequest_workaround(Display* dpy, CARD8 type, size_t len)
++{
++ xReq *req;
++ WORD64ALIGN
++ if (dpy->bufptr + len > dpy->bufmax)
++ _XFlush(dpy);
++ dpy->last_req = dpy->bufptr;
++ req = (xReq*)dpy->bufptr;
++ req->reqType = type;
++ req->length = len / 4;
++ dpy->bufptr += len;
++ dpy->request++;
++ return req;
++}
++
+ static int x11_load_refcount = 0;
+
+ void SDL_X11_UnloadSymbols(void)
+@@ -168,6 +183,15 @@ int SDL_X11_LoadSymbols(void)
+ X11_GetSym("XGetICValues",&SDL_X11_HAVE_UTF8,(void **)&pXGetICValues);
+ #endif
+
++ /*
++ * In case we're built with newer Xlib headers, we need to make sure
++ * that _XGetRequest() is available, even on older systems.
++ * Otherwise, various Xlib macros we use will call a NULL pointer.
++ */
++ if (!SDL_X11_HAVE_XGETREQUEST) {
++ p_XGetRequest = SDL_XGetRequest_workaround;
++ }
++
+ if (SDL_X11_HAVE_BASEXLIB) { /* all required symbols loaded. */
+ SDL_ClearError();
+ } else {
+--- a/src/video/x11/SDL_x11sym.h
++++ a/src/video/x11/SDL_x11sym.h
+@@ -170,6 +170,12 @@ SDL_X11_SYM(void,_XRead32,(Display *dpy,register long *data,long len),(dpy,data,
+ #endif
+
+ /*
++ * libX11 1.4.99.1 added _XGetRequest, and macros use it behind the scenes.
++ */
++SDL_X11_MODULE(XGETREQUEST)
++SDL_X11_SYM(void *,_XGetRequest,(Display* a,CARD8 b,size_t c),(a,b,c),return)
++
++/*
+ * These only show up on some variants of Unix.
+ */
+ #if defined(__osf__)
diff --git a/meta/recipes-graphics/libsdl/libsdl_1.2.14.bb b/meta/recipes-graphics/libsdl/libsdl_1.2.14.bb
index f587291b52..5b87f39647 100644
--- a/meta/recipes-graphics/libsdl/libsdl_1.2.14.bb
+++ b/meta/recipes-graphics/libsdl/libsdl_1.2.14.bb
@@ -15,10 +15,11 @@ PROVIDES = "virtual/libsdl"
DEPENDS = "${@base_contains('DISTRO_FEATURES', 'opengl', 'virtual/libgl', '', d)} virtual/libx11 libxext libxrandr libxrender tslib"
DEPENDS_virtclass-nativesdk = "libx11-nativesdk libxrandr-nativesdk libxrender-nativesdk libxext-nativesdk"
-PR = "r4"
+PR = "r5"
SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz \
file://configure_tweak.patch \
+ file://add.XGetRequest.symbol.patch \
"
S = "${WORKDIR}/SDL-${PV}"