summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libxsettings-client/libxsettings-client
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2010-09-25 10:16:26 +0800
committerSaul Wold <Saul.Wold@intel.com>2010-09-27 08:59:15 -0700
commitce456306dad3fdf42494830011dacae213c48edf (patch)
tree0dfca13c02aa1880a5353b21676cc48bd65834b9 /meta/recipes-graphics/libxsettings-client/libxsettings-client
parentb3ef7f59e2c7e7ea232b4a22bfaf423cd747c2a7 (diff)
downloadopenembedded-core-ce456306dad3fdf42494830011dacae213c48edf.tar.gz
gcc: enable poison parameters detection
If not configured with --enable-target-optspace, gcc will report errors if there is '-Os' optimization in parameters. This fixes [BUGID #342] Also add "--enable-target-optspace" option to arm gcc configuration. Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
Diffstat (limited to 'meta/recipes-graphics/libxsettings-client/libxsettings-client')
-rw-r--r--meta/recipes-graphics/libxsettings-client/libxsettings-client/disable_Os_option.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libxsettings-client/libxsettings-client/disable_Os_option.patch b/meta/recipes-graphics/libxsettings-client/libxsettings-client/disable_Os_option.patch
new file mode 100644
index 0000000000..716f562f67
--- /dev/null
+++ b/meta/recipes-graphics/libxsettings-client/libxsettings-client/disable_Os_option.patch
@@ -0,0 +1,17 @@
+Do not set Os optimization in target APP CFLAGS, since it may have potential
+error if "--enable-target-optspace" is not set when configuring GCC.
+
+Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
+
+diff -ruN Xsettings-client-0.10-orig/configure.ac Xsettings-client-0.10/configure.ac
+--- Xsettings-client-0.10-orig/configure.ac 2010-09-21 14:01:47.000000000 +0800
++++ Xsettings-client-0.10/configure.ac 2010-09-21 14:02:01.000000000 +0800
+@@ -3,7 +3,7 @@
+ AM_INIT_AUTOMAKE(Xsettings-client, 0.10)
+ AM_CONFIG_HEADER(config.h)
+
+-CFLAGS="-Os -Wall"
++CFLAGS="-O2 -Wall"
+
+ # Checks for programs.
+ AC_PROG_CC